Qt Creator on Raspberry Pi



  • Hey all,

    I recently acquired by Pi for Christmas, and have installed Qt Creator on it. I've used Qt Creator in the past, but didn't have any problems that I couldn't solve. Here, however, I'm stumped. When I try and compile a project, by clicking the build icon in the lower left-hand corner, I can build the project just fine. All the processes that this entails are completed correctly, and the compile output shows that. However, even after the project has been built, the Run and Debug buttons (which both require the program to be run) are grayed out. When I hover over them, a tooltip appears that says "Qt Creator doesn't know what to run". When I go to the Run/Build dialog box, above the run button, I only get options to select for the build. Above that, in the same box, for a project called untitled, it says "Run: Untitled (on Remote Linux Device)". What does this mean, does it have anything to do with my problem? I've tried using Google to find a solution, but all the ones I've found are for older versions of Qt Creator. Any idea what is going wrong, and how to fix it?


  • Moderators

    Welcome to the forum nounoua,

    Congratulations on your christmas present ;-)

    First of all we would like to know how you installed Qt creator and what version?

    By the way did you know we have a subforum dedicated to the Pi. I've moved this thread to it.
    Also in the wiki we have a subsection named qtonpi.



  • uncheck the "remote linux"
    at menu help > about plugins ---> device support
    as suggest by

    http://qt-project.org/wiki/apt-get_Qt4_on_the_Raspberry_Pi


  • Moderators

    Which run configurations are set up in your project? Which kits do you have defined?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.