Important: Please read the Qt Code of Conduct -

Bakeqtpi.bash script build error in QtBase

  • I've tried bakeqtpi.bash script to generate an image with Qt5 following the instructions at both in build machines Ubuntu 12.04 32-bit and Debian Wheezy 64-bit and I get the same build failure:

    .obj/release-shared/main.o: In function dumpRecursive(QDir const&, QTextStream&)': main.cpp:(.text+0x3ea): undefined reference toQDir::entryInfoList(QFlagsQDir::Filter, QFlagsQDir::SortFlag) const'
    main.cpp:(.text+0x3ea): undefined reference to QDir::entryInfoList(QFlags<QDir::Filter>, QFlags<QDir::SortFlag>) const' main.cpp:(.text+0x45f): undefined reference toQDir::QDir(QString const&)'
    main.cpp:(.text+0x476): undefined reference to QDir::~QDir()' .obj/release-shared/main.o: In functioncreateProject(QString const&)':
    main.cpp:(.text+0x572): undefined reference to QDir::currentPath()' main.cpp:(.text+0x57f): undefined reference toQDir::QDir(QString const&)'
    main.cpp:(.text+0x5aa): undefined reference to QDir::dirName() const' main.cpp:(.text+0x5c6): undefined reference toQFile::QFile()'
    main.cpp:(.text+0x5ef): undefined reference to QFile::open(_IO_FILE*, QFlags<QIODevice::OpenModeFlag>, QFlags<QFileDevice::FileHandleFlag>)' main.cpp:(.text+0x699): undefined reference toQFile::~QFile()'
    main.cpp:(.text+0x6bf): undefined reference to QDir::~QDir()' main.cpp:(.text+0x74d): undefined reference toQDir::QDir(QString const&)'
    main.cpp:(.text+0x769): undefined reference to QDir::~QDir()' main.cpp:(.text+0x7d9): undefined reference toQFile::setFileName(QString const&)'

    It seems it can't find the Qt libraries. Should I install qt5 libs on the build machine before running the script? I've already installed Qt5 SDK Beta 2.

  • So I've given another try, and the error above only seems to occur when I run the script again.
    If I do rm ~/opt/qt5, and run it again, it seems to go further, but fails with the error:

    @arm-linux-gnueabihf-g++: internal compiler error: Killed (program cc1plus)@

    dmesg indicates this is due to a lack of memory, but my Linux build machine has 4GB RAM, and I've already added 4GB swap. Do I need more than 8GB memory to build Qt5?

  • Updated the swap file to 8GB, and it's seems OK for now, but the build is very very slow.

Log in to reply