[SOLVED] Installing qt5 on a raspberry pi



  • I just managed to get my cross compiler working, and I am trying to make the hello-qtonpi project, that came with qtonpi to work.

    I added the repository, and used apt-get to install qt50-snapshot.

    My program gave me errors about a library (either QtCore, or QtQuick, can't remember). I exported LD_LIBRARY_PATH=/opt/qt50-snapshot/lib, and it gave errors about another library, libQtXmlPatterns.so. I looked at the libs, and a such file didn't exist. I assume that it is a module which was not built in the snapshot.

    There was a (I assume working) sdcard image with a new OS with the qtonpi. I looked at the libs that came with it, and it did contain the missing library. Just in case I tried rsync'ing the whole libs folder to my pi (assuming they would be compiled for the same platform, so they might have worked). After the copy, it started again giving errors on the first library, which did exist. The export did not fix it. Should I copy something more, or are they incompatible for some reason?

    What should I do to get a working QT5 on my pi? I also saw a guide on cross-compiling it with linaro, maybe I'll try that next, If I don't manage to get a answer to what I am doing wrong...



  • varesa,

    I have followed "this guide":http://qt-project.org/wiki/RaspberryPi_Beginners_guide with sucess (Fedora 16).

    I'm using wheezy (not qtonpi).



  • @TioRoy That guide indeed works as a charm.

    Though somewhere it says to unmount the image, which I did need mounted when working with Qt5 on QCreator (otherwise it says not installed properly)



  • You need to umount the image to copy it to SDCard. But to develop with QTCreator, you need to mount it again.

    I'm a newbie with Debian, but I'll try to mount (via NFS or SMB) a live Raspberry instead of an image.
    I think this will speed up the development.



  • Default Wheezy (Debian) kernel has no support to NFS.

    I follow this "link":http://elinux.org/R-Pi_NAS to setup Samba.



  • I am trying to compile it using the two guides in the qt wiki, including the on you pointed at, but I can't get very far.

    At first I was having an issue with the ./configure failing, but I managed to fix that ("my other thread":http://qt-project.org/forums/viewthread/21017/).

    Now it hangs at make. Here is the last command run by make, and its output: https://gist.github.com/4156911

    I have added rough translations at the few last line, because some of the words are in Finnish, but I think you could have figured them out anyway.

    Any ideas on how to fix?



  • Are you sure that the double slash between rpi_image and opt is correct?

    /home/esa/qtonpi/rpi_image//opt/vc/lib



  • [quote author="Stijnb" date="1354120785"]Are you sure that the double slash between rpi_image and opt is correct?

    /home/esa/qtonpi/rpi_image//opt/vc/lib
    [/quote]

    I think it is an artifact created by the sysroot parameter having a slash in the end, but it should not create any trouble, atleast the 100 lines before it have the same thing without problems. Good observation though.

    From quick googling:
    Multiple slashes are allowed and are equivalent to a single slash. From the Single Unix specification (version 3), base definitions §3.266 pathname: “Multiple successive slashes are considered to be the same as one slash.”



  • I managed to fix this by choosing a correct sysroot. The one it was pointing at had a broken symlink, which caused the library to fail


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.