Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can’t install qt50-snapshot to Raspberry Pi



  • I successfully created cross-compiler environment on my linux mint laptop. I used this 2012-09-18-wheezy-raspbian.img rasbian image, and configured and compiled qt5 to that image using this quide page. Then I copied that image to memorycard, and raspberry worked perfectly. Network is working and ssh communication from my laptop has been success.
    http://qt-project.org/wiki/RaspberryPi_Beginners_guide

    I managed to compile helloworld example in my qt creator, but I failed to deploy it to raspberry. I added Tools->Options->Linux Devices->Add->Generic Linux Image, like the quide said. Device test was successful,

    BUT in projects menu (Run settings & deployment) there was no possibility to select my configured raspberry pi. After lots of googling, I found this thread http://qt-project.org/forums/viewthread/19697 and couple other pages.

    So I think I need to install qt50-snapshot to my raspberry, but it didn't go like in the movies.

    1. I added "deb http://archive.qmh-project.org/rpi/debian/ unstable main" line to /etc/apt/sources.list

    2. Then I run "sudo apt-get update"
      @...
      Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
      Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
      Err http://archive.qmh-project.org unstable/main armhf Packages
      404 Not Found
      Ign http://archive.qmh-project.org unstable/main Translation-en
      W: Failed to fetch http://archive.qmh-project.org/rpi/debian/dists/unstable/main/binary-armhf/Packages 404 Not Found

    E: Some index files failed to download. They have been ignored, or old ones used instead.
    pi@raspberrypi ~ $ @

    1. Then "sudo apt-get install qt50-snapshot"
      I didn't obviously found this package also, so the installation was failed

    I tried to find that package with my linux mint also, and the result was same. Seems like there is Packages.gz in that site and other stuff. Is there some bug?? Can you guys find that package on your own computers? What should I do? Is there another way to install this qt50-snapshot, some mirror site perhaps?



  • Hi,
    I am having the same issues. I am struggling with using Qt on RPI for a week. It is annoying not able to deploy after compiling. Have you solved the problem since then?



  • I managed to install qt50-snapshot when I used "deb http://archive.qmh-project.org/rpi-wheezy/debian unstable main" line in /etc/apt/sources.list. I didn't get my cross-compile environment to work though. My Qt creator doesn't found target device after I installed qt50-snapshot.


Log in to reply