Qt5 on raspberry pi - OpenGL ES 2.x disabled.



  • Hi, i have a question because i cant find nothing on google... everything just wont work for me...

    i'am using this guide http://qt-project.org/wiki/RaspberryPi_Beginners_guide
    and i'am stuck at ./configure step with following errors:
    @<srcbase> = /home/pi/opt/qt5/qtbase
    <outbase> = /home/pi/opt/qt5/qtbase
    Creating qmake. Please wait...
    make: Nothing to be done for `first'.
    Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
    Note: PKG_CONFIG_SYSROOT_DIR automatically set to /mnt/rasp-pi-rootfs
    Determining architecture... ()
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++ -c -pipe -marm -mfpu=vfp -mtune=arm1176jzf-s -march=armv6zk -mabi=aapcs-linux -mfloat-abi=hard --sysroot=/mnt/rasp-pi-rootfs -g -Wall -W -fPIE -I../../mkspecs/devices/linux-rasp-pi-g++ -I. -o arch.o arch.cpp
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: 1: /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: Syntax error: "(" unexpected
    make: *** [arch.o] Error 2
    Unable to determine architecture!

    Could not determine the target architecture!
    Turn on verbose messaging (-v) to see the final report.
    Determining architecture... ()
    g++ -c -pipe -g -Wall -W -fPIE -I../../mkspecs/linux-g++ -I. -o arch.o arch.cpp
    g++ -o arch arch.o
    { test -n "" && DESTDIR="" || DESTDIR=.; } && test $(gdb --version | sed -e 's,[^0-9]+([0-9]).([0-9]).*,\1\2,;q') -gt 72 && gdb --nx --batch --quiet -ex 'set confirm off' -ex "save gdb-index $DESTDIR" -ex quit 'arch' && test -f arch.gdb-index && objcopy --add-section '.gdb_index=arch.gdb-index' --set-section-flags '.gdb_index=readonly' 'arch' 'arch' && rm -f arch.gdb-index || true
    Found architecture in binary
    CFG_HOST_ARCH="arm"
    CFG_HOST_CPUFEATURES=""
    System architecture: 'unknown'
    Host architecture: 'arm'
    C++11 auto-detection... ()
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++ -c -pipe -marm -mfpu=vfp -mtune=arm1176jzf-s -march=armv6zk -mabi=aapcs-linux -mfloat-abi=hard --sysroot=/mnt/rasp-pi-rootfs -O2 -std=c++0x -Wall -W -fPIE -I../../../mkspecs/devices/linux-rasp-pi-g++ -I. -o c++11.o c++11.cpp
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: 1: /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: Syntax error: "(" unexpected
    make: *** [c++11.o] Error 2
    C++11 disabled.
    ...
    a lot of errors about disabled libs
    ...
    OpenGL ES 2.x auto-detection... ()
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++ -c -pipe -marm -mfpu=vfp -mtune=arm1176jzf-s -march=armv6zk -mabi=aapcs-linux -mfloat-abi=hard --sysroot=/mnt/rasp-pi-rootfs -O2 -Wall -W -fPIE -I../../../mkspecs/devices/linux-rasp-pi-g++ -I. -I/mnt/rasp-pi-rootfs/opt/vc/include -I/mnt/rasp-pi-rootfs/opt/vc/include/interface/vcos/pthreads -o opengles2.o opengles2.cpp
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: 1: /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: Syntax error: "(" unexpected
    make: *** [opengles2.o] Error 2
    OpenGL ES 2.x disabled.
    The OpenGL ES 2.0 functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in
    /home/pi/opt/qt5/qtbase/mkspecs/devices/linux-rasp-pi-g++.
    @

    and my ./configure looks like this:
    @/configure -opengl es2 -device linux-rasp-pi-g++ -device-option CROSS_COMPILE=/home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/rasp-pi-rootfs -opensource -confirm-license -optimized-qmake -release -make libs -prefix /usr/local/qt5pi -v
    @
    i had to remove -reduce-relocations -reduce-exports because there were some errors with them, and what is with that syntax error in arm-linux-gnueabihf-g++ ?
    i have fresh install of raspbian, i also made all steps from troubleshooting section of guide

    thanks for any help



  • i tried one more time from begining using bakeqtpi.bash from link in post above, and it stopped at:
    @
    /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: 1: /home/pi/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-g++: Syntax error: "(" unexpected
    -reduce-exports was requested but this compiler does not support it
    Re-run configure with -v for more information
    Configuring QT Failed
    @



  • Hi,
    It seems like a long time ago. Do you remember how you manage to solve this?
    I ve been trying diffent linux versions, some gives that error some not..

    Or
    Maybe I should ask, Did you succeed by using the tutorial that u mentioned above ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.