QtonPi SD Card image with RaspberryPi



  • Hi,
    Has anyone tried with Qtonpi SD card image. I have tried using **# bzcat qtonpi-sdcard-0.2.img.bz2 > /dev/sdb; sync ** (from SD card image section of http://qt-project.org/wiki/Create#1b825bfe50d3793bdec3827e53945528)

    The image seemed to have copied OK, but when I tried to boot the RPi board, it didn't boot. Following is what tried in my Linux terminal.

    @sarath@ubuntu:/dev$ sudo fdisk -l
    [sudo] password for sarath:

    Disk /dev/sda: 17.2 GB, 17179869184 bytes
    255 heads, 63 sectors/track, 2088 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00032a41

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 2038 16368640 83 Linux
    /dev/sda2 2038 2089 407552 5 Extended
    /dev/sda5 2039 2089 406528 82 Linux swap / Solaris

    Disk /dev/sdb: 1990 MB, 1990197248 bytes
    64 heads, 63 sectors/track, 964 cylinders
    Units = cylinders of 4032 * 512 = 2064384 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 964 1943358+ 6 FAT16

    root@ubuntu:/home/sarath/Desktop/qtonpi-0.2/sdcard-img# pwd
    /home/sarath/Desktop/qtonpi-0.2/sdcard-img
    root@ubuntu:/home/sarath/Desktop/qtonpi-0.2/sdcard-img# bzcat qtonpi-sdcard-0.2.img.bz2 >/dev/sdb1; sync
    root@ubuntu:/home/sarath/Desktop/qtonpi-0.2/sdcard-img# @

    There was a lot of wait after the last command as I believe the image was copied to card. I was using ubuntu 10.04 with VmWare Player.I have tried couple of times, but of no use. I have the Debian squeeze image working with another SD card on the same board. So board is powered correctly and no hardware issues.
    Can someone please help resolve this....

    Thanks in Advance
    Smartsarath2003



  • The 0.2 image definitely works as I've been running with it for the last couple of weeks. I put the image onto the SD card from Windows, so I can't help with the Linux side of things.



  • Hi,
    Did you used any tool to copy image in windows or did you copied over just like a normal file on disk. I remember I tried this in windows with 0.1 image (FAT16 2GB SD card) and it didn't worked. I will try again with 0.2..
    Thanks



  • I used Win32DiskImager to write the SD card image, I followed the instructions "here":http://www.raspberrypi.org/downloads to install it. You can't just drag the image onto the card.



  • It works for me also. I use Ubuntu to copy the image to the SD card.



  • Hi
    Win32DiskImager did worked when I tried on different laptop.
    I can't use this tool on my laptop as this tool doesn't recognize SD card drive, so I used flashnul and linux method which didn't worked
    Thanks for the help



  • This reply may be too late to be useful, but in case it's helpful:

    This line @bzcat qtonpi-sdcard-0.2.img.bz2 >/dev/sdb1; sync@

    should be @bzcat qtonpi-sdcard-0.2.img.bz2 >/dev/sdb; sync@

    Note sdb not sdb1.
    I installed QtonPi this way and it worked fine.

    Thomas



  • I have had the same problem. Did you manage to sort the problem out. If so, how did you do it?

    Thanks



  • I have the same issue, but not with rasperian :-( I have the 512Mb version, I'm thinking that is the issue ?????

    Has anybody got it working on RPi 512Mb??


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.