Qt 4.7.1 was released today



  • yay!



  • Yeah, and QtMobility released too :)



  • Great!
    I hope it solve the problem I described "here":http://developer.qt.nokia.com/forums/viewthread/1085/





  • waiting Qt 4.7 on symbian^3:) (not developer build:)



  • [quote author="Alexander Kuchumov" date="1289303463"]waiting Qt 4.7 on symbian^3:) (not developer build:)[/quote]

    In SEE2010 today it was announced that PR 1.2 for N8 would be released by Jan 2011 and will contain more than 50+ features. Am sure Qt 4.7 would be supported in that.



  • QtK, It's good news:)



  • Will the updates be available via update utility in Nokia Qt SDK, or do I have to install the new SDK from scratch?



  • [quote author="zolakt" date="1289323868"]Will the updates be available via update utility in Nokia Qt SDK, or do I have to install the new SDK from scratch?[/quote]

    For some unknown reason I am unable to update or uninstall the old SDK from my system. It is always giving error unable to connect to server.

    I think this should be fixed in Nokia Qt SDK, if someone wants to uninstall in offline mode also it should allow.



  • Agreed. Offline mode should be also supported :)

    It does not allow uninstall if I cannot connect to server and it DOES NOT connect to the server from my office network. So finally had to just delete the whole folder and reinstall the new version in the same location



  • [quote author="chetankjain" date="1289375573"]Agreed. Offline mode should be also supported :)

    It does not allow uninstall if I cannot connect to server and it DOES NOT connect to the server from my office network. So finally had to just delete the whole folder and reinstall the new version in the same location [/quote]

    Initially, i thought it was due to my office firewall. But it doesn't even connect to server from my Home Network or other open network. Seems there is some issue with their server.



  • I have installed Nokia Qt SDK in offline mode.
    Everything was working fine until now.
    I got all the newest updates.

    I mean there is nothing wrong now also.
    But I just don't have any available updates in update utility.

    So do I need to uninstall this and install the new SDK.
    Or do I just need to wait for the update to appear?



  • [quote author="zolakt" date="1289397319"]I have installed Nokia Qt SDK in offline mode.
    Everything was working fine until now.
    I got all the newest updates.

    I mean there is nothing wrong now also.
    But I just don't have any available updates in update utility.

    So do I need to uninstall this and install the new SDK.
    Or do I just need to wait for the update to appear?[/quote]

    Since you might have just downloaded and installed the latest Nokia Qt SDK, you don't have anything to update.

    We were discussing about updating the older versions of SDK or uninstalling the same in offline mode.



  • Tried from my home network, Nokia sdk smart installer works fine and is pulling in latest updates.. so it is the firewall at office :(



  • [quote author="chetankjain" date="1289405038"]Tried from my home network, Nokia sdk smart installer works fine and is pulling in latest updates.. so it is the firewall at office :([/quote]

    Yes last time I tried it worked from my home network, but this time it didn't. So I feel the server goes down at sometimes.

    Whatever the case may be user should be given an option to uninstall the sdk without connecting to the server.



  • [quote author="QtK" date="1289404881"]
    Since you might have just downloaded and installed the latest Nokia Qt SDK, you don't have anything to update.

    We were discussing about updating the older versions of SDK or uninstalling the same in offline mode.[/quote]

    No, I didn't download the latest version.
    I have the old 1.0.1. offline installed.
    Latest update was for qt 4.7, when pr1.3 for maemo arrived.

    Do I need to install the 1.0.2. Nokia Qt SDK or it will be available via update utility?



  • I have downloaded Nokia SDK 1.0.2 (not installed yet).
    The installer says that it includes Qt 4.7.0 not 4.7.1
    and Qt mobility 1.0.2 not 1.1.0.

    I'm confused here. How can I install the new Qt and mobility update on Nokia SDK?



  • go ahead and install nokia sdk 1.0.2 .. you can try to fetch the latest versions with smart installer later .. but not sure if the smart installer will fetch 4.7.1 and 1.1

    you can try to install them separate and update your settings to use them instead ---
    mobility installation instructions "here":http://doc.qt.nokia.com/qtmobility-1.0/installation.html



  • can someone tell me how to install QtMobility 1.1.0. on Nokia Qt SDK 1.0.2. ?

    basically I want to add support for mobility classes to QtCreator and include them in Maemo toolchain, so I can run it on my device with mobility installed

    I read the instructions, but it doesn't work for me
    configure command doesn't execute
    btw. SDK installed on windows 7

    when run in cmd, outputs:
    [QUOTE]Checking available Qt
    \PC was unexpected at this time[/QUOTE]

    when run in vs2008 cmd, outputs:
    [QUOTE]Checking available Qt
    \Microsoft was unexpected at this time[/QUOTE]

    when run in madde terminal, outputs:
    [QUOTE]Checking available Qt.. Not found
    Cannot find qmake in your PATH
    Aborting.[/QUOTE]



  • greate news!!!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.