Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Import Qt5Compat with PySide6 in QML file



  • Hey, I have a PySide6 project in which I want to import Qt5Compat.GraphicalEffects.
    Qt Creator shows me QML module not found error.
    When I run the project it throws module "Qt5Compat.GraphicalEffects" is not installed error.

    I've checked the installed packages on my archlinux machine and I have qt6-5compat installed.

    Is there a way to use Qt5Compat with PySide6?



  • Yes, there is. I found out that Qt5Compat is coming to Qt 6.1. So any version of Qt or PySide6 below 6.1 won't have this module.
    I managed to import and use it by installing dev snapshot wheels of PySide6 6.1.0. You can find them here:

    https://download.qt.io/snapshots/ci/pyside/dev/latest/pyside2/

    Regards.



  • Well, I guess I'll have to wait for Qt 6.1 or compile it myself ;/