[Решен] Qt3D проблем



  • имам инсталирана най-нова версия на Qt Creator, слагам кода от "тук":http://doc.qt.nokia.com/qt3d-snapshot/qml-camera.html
    @ import Qt 4.7
    import Qt3D 1.0

    Viewport {
    width: 640; height: 480
    camera: Camera {
    eye: Qt.vector3d(-1, 2, 10)
    }
    light: Light {}
    Item3D {
    mesh: Mesh { source: "meshes/teapot.bez" }
    effect: Effect {}
    }
    }@

    и ми изписва тази грешка
    @module "Qt3D" is not installed
    import Qt3D 1.0
    ^ @



  • Maybe:
    [quote]This element was introduced in Qt/3D 4.8.[/quote]



  • Camera елемента се появява в Qt 4.8. както е посочил RazrFalcon, но проблема според мен е, че не ти намира Qt3D, това е допълнителен модул и мисля, че не идва с основната инсталация. Провери дали е инсталиран при теб и дали е в importPath-а на QML-а.



  • [quote author="task_struct" date="1319698597"]Camera елемента се появява в Qt 4.8. както е посочил RazrFalcon, но проблема според мен е, че не ти намира Qt3D, това е допълнителен модул и мисля, че не идва с основната инсталация. Провери дали е инсталиран при теб и дали е в importPath-а на QML-а.[/quote]

    как да го инсталирам ?



  • Пробвай "тези инструкции":http://doc.qt.nokia.com/qt3d-snapshot/qt3d-building.html



  • Къде въвеждам тези ?
    @
    $ mkdir -p $HOME/depot/qt
    $ cd $HOME/depot/qt
    $ git clone git://gitorious.org/qt-quick3d/qt-quick3d.git
    @



  • Ами командите са за Линукс конзола. Ако си с Windows или Mac e малко по-различно. Как ОС ползваш?



  • [quote author="task_struct" date="1319788145"]Ами командите са за Линукс конзола. Ако си с Windows или Mac e малко по-различно. Как ОС ползваш?[/quote]

    windows



  • Ами, ще трябва да си инсталираш git или мисля, че може да минеш само като си свалиш кода на готов пакет - https://gitorious.org/qt-quick3d/qt-quick3d/archive-tarball/master . Разархивираш го, компилираш и инсталираш.



  • това стана за windows приложения, обаче като компилирам за qt simulator отново ми дава грешки



  • Мисля, че Windows версията търси плъгините за QML при инсталацията на Qt, a Qt Simulator някъде в SDK-то, където са и .sis пакетите за дадения телефон. Може би трябва да билднеш Qt 3D за Симулатор/Телефон или поне да му настроиш пътищата да търси и на други места.



  • стана мерси много ако има някакви точки или нещо подобно в този форум ми кажи как да ти дам ?



  • Всеки получава точки за всеки отговор, който напише :)

    Има конвенция, на решените теми да се редактира заглавието като се добави [Решен] отпред. Това стига :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.