Qt for WebAssembly



  • hola a todos

    estoy siguiendo las instrucciones de este link
    https://blog.qt.io/blog/2018/11/19/getting-started-qt-webassembly/

    todo iba muy bien hasta ejecutar este comando
    $ ~/Qt/5.12.0/Src/configure -xplatform wasm-emscripten -nomake examples -prefix $PWD/qtbase

    despues de un buen rato me sale el siguiente error

    In file included from ../../include/QtCore/5.12.3/QtCore/private/qsimd_p.h:1:
    ../../include/QtCore/5.12.3/QtCore/private/../../../../../src/corelib/tools/qsimd_p.h:196:14: fatal error: 'x86intrin.h' file not found

    include <x86intrin.h>

    1 error generated.
    shared:ERROR: compiler frontend failed to generate LLVM bitcode, halting
    a alguno le a pasado?
    como puedo solucionarlo?
    gracias



  • @Weimars
    ¿Qué versión de Emscripten estás usando? Qt 5.12 needs 1.38.16

    ./emsdk install sdk-1.38.16-64bit
    ./emsdk activate --embedded sdk-1.38.16-64bit

    Los binarios de Qt para WebAssembly están disponibles en Qt 5.13-beta, que necesita Emscripten 1.38.27

    Lo sentimos, traducción por google. :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.