Just an update. It looks like the QtCreatorDeployment.txt file is only taken into account by CMake Project or Generic Project. So I created a Generic Project, add the Python file(s) to the .files file, removed all the steps from the Build Settings tab, and configured the Run Settings with a Custom Executable where I set python as the remote executable, and main.py as the command line arguments while enabling Forward to local display. And it worked :-)