@jsulm thanks I fixed it now. It was a stupid mistake, not setting up the static variable.