Are you using MinGW kit? This is a MSVC lib. You need to install MSVC build tools and use MSVC version of Qt.