Important: Please read the Qt Code of Conduct -

5.12.1 build problem (Windows, VS2017-based, incomplete build)

  • I didn't touch Qt's build system for some time. Now some of my scripts are seemingly broken:

    System: Win10, VS2017,

    configure arguments (batch variables are hopefully self-explanatory):

    set CONFIGUREARGS=-opensource ^
     -confirm-license ^
     -opengl dynamic ^
     -platform %VCPLATFORM% ^
     -nomake examples ^
     -nomake tests ^
     -make-tool jom ^
     -skip qtwebengine ^
     -prefix %INSTALL_DIR% 

    The dll's are build and even the basic executables (qmake, rcc, moc, uic etc.) but nothing from qttools. I'm in particular interested in Qt designer.
    After unsuccessfully fiddling with pro files and some feature settings I discovered by accident the new json-based configuration system. It seems I have to overwrite something there, in order to build the tools. How can I do this (especially from outside - whole out-of-source build, not touching anything inside the source tree)? Are there recipes for my case, or even better something along 'build Qt together with all/most tools' ? The only documentation I was able to find (here) , doesn't answer all of these questions.

  • Solved. Win 10 SDK was missing - contrary to the fact, that Visual Studio installed one. But only an up-to-date self-contained SDK iso worked.

Log in to reply