Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

5.12.1 QWebEngine ClientSSL's Example



  • I saw in the patch change notes that Client SSL certificates were now support in 5.12.1. So I loaded the SimpleBrowser example.
    When I ran it (built with MSVC2017 64bit) and then pointed it to a internal lan server that uses a Self Signed Client SSL authentication system. The example crashed.

    alt text
    alt text

    So i put the example in debug, cleaned and rebuilt it. When i Ran it and pointed at the same server. The Application hangs up and gives this output, but does not kick over for a debug.

    [12564:14860:0219/131011.251:WARNING:backend_impl.cc(1841)] Destroying invalid entry.
    

    Then when i trying to stop the debuging. I can not. In fact i have to go into the task manager and kill cdb to get the program to terminate.

    So at the moment it looks like the problem is located inside chromium, but can not say for sure. Since the example code doesn't want to run in debug mode when dealin with SSL's. Chrome it's self DOES load the site and client SSL properly.

    So at the moment i'm unsure where to go from here.


Log in to reply