Flickering during repaint on Ubuntu 16.04



  • Hi !

    I am working on a QML application (based on ApplicationWindow in QML and QQmlApplicationEngine in c++)

    I am developing it on both windows & Arch Linux + Gnome 3 where it works flawlessly.
    Lately, I tried to run it on Ubuntu 16.04 and the application is flickering during repaint (white flashes that cover the whole window when the UI is repainted, even partially). Sometimes, even the Ubuntu's Unity dock is flickering.

    I noticed that :

    1. It does not happen if my application is in fullscreen mode
    2. It does not happen if the application is not maximized

    It only happen when the application is maximized (and the titlebar is merged with Unity top bar). I have absolutely no idea what could cause this and where I should start searching for the solution.

    Any idea on what could be the cause of the flickers ?
    Thanks


  • Lifetime Qt Champion

    Hi,

    What version of Qt are you using ?



  • The flickering happens in both Qt5.10 and Qt5.12.


  • Lifetime Qt Champion

    Can you be more precise ? Qt 5.12 is now at Qt 5.12.1

    Do you get the same behaviour if you use your distribution provided Qt ?



  • Right now, the machine uses Qt5.12.0 (downloaded & installed using the installer tool provided by Qt since 5.12 is not available in the packages provided by Ubuntu 16.04).

    Sadly, I cannot test on Ubuntu 16.04 provided Qt because I rely on features introduced in Qt5.12 which is not available.

    Is Ubuntu 16.04 (Unity) not supported by Qt5.12 ?


  • Lifetime Qt Champion

    Ubuntu may have applied patches to Qt to integrate with their desktop environment that may or may not have implication with your current problem.

    Can't you disable the specific feature you are using just to test your application ?



  • The Qt version available in the default packages is Qt5.5. That would force me to disable a lot of features. Guess I have to drop Ubuntu 16.04 support for now until I have some time to try to make it work with Qt5.5


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.