Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

JOM error after VS2017 update?!



  • Hi,
    I just updated VS 2017 to version 15.9.5. After than this update my Qt-creator started to giv error ike below,

    :-1: error: cannot open C:\Users\ÇUKUROVA SİLO PC1\AppData\Local\Temp\uretimlistesiicerialma.obj.7512.172.jom for write

    And comiper error:
    12:04:13: Starting: "D:\ProgramFiles\Qt\Tools\QtCreator\bin\jom.exe"
    D:\ProgramFiles\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    SHGetSpecialFolderPath() failed for standard location "Shared Configuration", clsid=0x1c. (Sistem belirtilen yolu bulamıyor.)
    D:\ProgramFiles\Qt\5.10.1\msvc2017_64\bin\uic.exe ..\CSI_Yonetim\uretimlistesiicerialma.ui -o ui_uretimlistesiicerialma.h
    Error: cannot open C:\Users\ÇUKUROVA SİLO PC1\AppData\Local\Temp\uretimlistesiicerialma.obj.7512.172.jom for write
    jom: D:\Belgeler\qt\build-CSI_Yonetim-Desktop_Qt_5_10_1_MSVC2017_64bit-Debug\Makefile [debug] Error 1
    12:04:13: The process "D:\ProgramFiles\Qt\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project CSI_Yonetim (kit: Desktop Qt 5.10.1 MSVC2017 64bit)
    The kit Desktop Qt 5.10.1 MSVC2017 64bit has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    12:04:13: Elapsed time: 00:00.

    https://stackoverflow.com/questions/9408466/qt-compile-time-error

    I unchecked like befor and now start to compile but very slow!..

    Regards,
    Mucip:)



  • Just clean the build directory completely and it should work



  • Hi,
    I already trayed is but did now work. I also downloaded newest jom and put usual location but same error...

    :-1: error: cannot open C:\Users\ÇUKUROVA SİLO PC1\AppData\Local\Temp\main.obj.6748.1016.jom for write

    Compiler output:
    Error: cannot open C:\Users\ÇUKUROVA SİLO PC1\AppData\Local\Temp\main.obj.6748.1016.jom for write
    jom: D:\Belgeler\qt\build-CSI_Yonetim-Desktop_Qt_5_10_1_MSVC2017_64bit-Debug\Makefile [debug] Error 1
    12:57:33: The process "D:\ProgramFiles\Qt\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project CSI_Yonetim (kit: Desktop Qt 5.10.1 MSVC2017 64bit)
    The kit Desktop Qt 5.10.1 MSVC2017 64bit has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    12:57:33: Elapsed time: 00:01.

    Regards,
    Mucip:)



  • Hi @VRonin
    I follow below link:
    https://stackoverflow.com/questions/9408466/qt-compile-time-error

    I can reproduce this problem if I check "Clear system environment" on the Projects' Build Settings page. Try unchecking that box.

    I checked "Clear System Environment"... Now all is fine.. :)

    Regards,
    Mucip:)



  • Hi @VRonin,
    I still have this problem?!
    What can I solve it?... I can not run with jom!

    Regards,
    Mucip:)


  • Lifetime Qt Champion

    Hi,

    @Mucip said in JOM error after VS2017 update?!:

    C:\Users\ÇUKUROVA SİLO PC1\AppData\Local\Temp\

    Can you check the access rights up to that folder ?

    And just to be sure, can you also check whether you still have that problem if you login with a user that doesn't have space nor non-ASCII chars in its name ?



  • Dear @SGaist
    I can create some file and delete it from same location by Explorer. And I guess that it's not about the user privilages...

    Untill VS update I was usinf same user name and home location. I didi not change anything unfortunately... :(

    Regards,
    Mucip:)


  • Lifetime Qt Champion

    I didn't wrote you were responsible. It's just some additional checks to determine what could be going wrong.



  • Dear @SGaist ,
    Sure. No problem. All we are trying to solve problem... ;)
    I guess it's about VS update... :(
    But I don't know why?

    Regards,
    Mucip:)


  • Lifetime Qt Champion

    @Mucip

    I can't tell often enough: Please avoid non-ASCII characters or spaces in project or build folders.

    You have a third problem: the temp folder. I'd use the hammer and create a folder C:\Temp and set the Windows environment variable TEMP to that. You have a good chance, that this solves your problem.



  • Dear @aha_1980 ,
    Changing TEMP path to c:\temp solved my problem... :)

    Thanks.

    Regards,
    Mucip:)


Log in to reply