Qt IFW components.xml missing



  • Hello,

    I'm using Qt IFW to create my setup.

    When I use it it does not create components.xml.
    If I try maintenancetool to remove it, I got corrupt installation message.

    How to solve it ?

    Best regards.



  • @Ben-92

    Hi and welcome to devnet

    What is the OS on creation and installation machine?

    Any (error) message during installation?



  • Hello,

    I'm under Windows 10.
    I create the setup under windows 10. 64 bits
    I run the setup on 5 laptop or desktop computer but always got errors.

    The message is: "Tour installation seems to be corrupted. Please consider re-installing from scratch.

    Few Time, setup create components.xml file in root directory near maintenancetools.exe.

    When I git this error message, this file is always missing.



  • @Ben-92

    Just to make sure.My understanding that you are referring to your own application deployed and the error occurs when you are starting the maintenance tool deployed with your application.

    Anyway, if there was no specific error while you have installed or maintained your application and afterwards the components.xml was missing, there is basically no real information what might have happened.

    I have had the same error message for my whole Qt installation (Creator and a bunch of different Qt versions). Unfortunately I did not monitor if there was also components.xml missing. After a while I tried to delete the whole installation through maintenance tool, but that did not succeed. Probably half of installation was not removable by maintenance tool. At the end I removed all and I did a fresh reinstall.



  • @koahnig

    Yes I agree with you. i could remove it and reintsall it after.

    in one part of software, I call miantenancetools with parameters in silent mode to check update. With this ssue, it cannt run properly and always dispaly a message. "Tour installation seems to be corrupted. Please consider re-installing from scratch."



  • @Ben-92

    Possibly this is related to this bug report. It has been resolved triggering the hope that it will not occur with new maintenance tool.

    Anyway I am not sure if the maintenance tool will be updated automatically or if you have initiate an update.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.