Qt Creator 4.8.0 doesn't launch in Ubuntu 18.04.



  • I installed Qt Creator together with Qt 5.12.0.
    I'm running into problems when trying to launch Qt Creator.
    When executed by the desktop icon, nothing happens.
    When I run ./qtcreator at the terminal, this is the output:

    ConnectionServer error: "QLocalSocket: Remote closed" "/tmp/QtCreator-qaoVOa/ClangBackEnd-4751"
    Segmentation fault (core dumped)
    

    When executing sudo ./qtcreator, this is the output:

    QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
    ConnectionServer error: "QLocalSocket: Remote closed" "/tmp/QtCreator-QRQtRi/ClangBackEnd-4808"
    Segmentation fault
    

    There is a simple way to solve this issue?

    I know that the Qt Creator currently at the Ubuntu repository works fine. But is an older version, could I use it without running in significant problems together with Qt 5.12.0? Just in the case where there is no clear solution to my problem.

    Maybe useful information:

    • I used the online installer.
    • I installed in both user and root mode, the same error in both situations.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Can you launch Qt Creator through your debugger ? That way you'll be able to get a backtrace of the error and find some hints about what is happening.



  • I never done this before, so I'm sorry if what is below isn't what you are looking forward.

    I open the terminal at the Qt Creator location and executed gdb qtcreator, after this I did the run gdb command, here is the output:

    Starting program: /opt/Qt/Tools/QtCreator/bin/qtcreator 
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
    [New Thread 0x7fffed813700 (LWP 31086)]
    [New Thread 0x7fffe284e700 (LWP 31087)]
    [New Thread 0x7fffe204d700 (LWP 31088)]
    [New Thread 0x7fffdbfff700 (LWP 31089)]
    [New Thread 0x7fffbce20700 (LWP 31094)]
    [New Thread 0x7fffb7fff700 (LWP 31095)]
    [New Thread 0x7fffb77fe700 (LWP 31097)]
    [Thread 0x7fffb7fff700 (LWP 31095) exited]
    [New Thread 0x7fffb6ffd700 (LWP 31098)]
    [New Thread 0x7fffb67fc700 (LWP 31112)]
    [New Thread 0x7fffb4dfd700 (LWP 31119)]
    
    Thread 1 "qtcreator" received signal SIGSEGV, Segmentation fault.
    0x00007fffccf3dd1e in Android::Internal::AndroidToolChain::detectSupportedAbis() const () from /opt/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so
    
    

    Is this what you wanted me to do?


  • Qt Champions 2018

    @Oshio

    Yeah, looks pretty good.

    What we can see is a crash while detecting the Android toolchains. Do you have tools for Android development installed?



  • @aha_1980
    Yes, these are the paths:

    /home/user/Android/Sdk
    /opt/android-studio/android-ndk-r10e

    Looking at my PATH variable, I can't see any reference to the paths above, could these be an issue?


  • Qt Champions 2018

    @Oshio I honestly don't know, never done Android development.

    Have you used them before with Creator (an older version e.g.)?



  • @aha_1980
    I needed to create an Android app a while ago, when I was using Ubuntu 16.04 and everything works fine.

    I upgraded to Ubuntu 18.04 and everything have become a mess, I uninstalled the previous Qt, but when I used the online and offline installer, every Qt version that I attempted (more than 3) to install, freezes in the middle of the process. Then, I installed the default version at the repository, from this point, the kits for Android development were not available and at the configuration options for Android there was a warning that kit could not be created automatically. I searched for solutions for a while and when nothing solved my problem I tried the online installer once again, I was hopping that the new version 5.12.0 could run without any troubles, the installation finishes apparently successful without warnings or errors, but the Qt Creator doesn't launches.

    This is the history on how I came here asking for help.

    I'd like to solve this to not have the headache of downgrading my Ubuntu.


  • Lifetime Qt Champion

    Since you have Qt 5.12, one thing you can do is to update to the latest NDK that uses clang.



  • Hi, also if you don't need the Android stuff right now, you could try disabling the Android plugin.
    In Qt Creator it's in the Help menu, About Plugins. But since your Qt Creator doesn't start, instead you can try deleting (or renaming) the .dll itself: /opt/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so



  • I found the solution for the primary issue.

    I follow @SGaist's suggestion to update the NDK, first I searched how to uninstall the previous version of NDK, then I discover its path should be in system Path variable. As you can read in one of my previous comment there was no reference to NDK at my PATH variable, maybe it got erased when I upgraded my Ubuntu or maybe I deleted without noticing, not sure.

    After this I performed the following steps, in order of appearance:

    • Delete NDK older version;
    • Update Android SDK, older version was 1 year old at least (I forgot to see the version before updating);
    • Downloaded newest NDK stable version, r18b at the time this post is written;
    • Added the NDK version r18b path to PATH variable. In my case I added it using the ~/.bashrc file and reloaded with source ~/.bashrc;
    • Launch the Qt Creator using desktop launcher;

    Qt Creator opens!

    I have one question before tagging this topic as solved.

    Every Example Project that I try to build using one of the Android kits, gives the error:

    /opt/Qt/5.12.0/android_armv7/include/QtCore/qglobal.h:45:12: fatal error: 'type_traits' file not found

    Is this related or should I tag as solved and open another topic?


  • Qt Champions 2018

    @Oshio I'd create a new topic for that to get more attention. Looks like a compiler issue...



  • Here is the link to the new topic regarding the build error.

    Thanks for helping me guys!


  • Qt Champions 2018

    @Oshio

    There is now also QTCREATORBUG-21780. You can track and comment it to get more information about the problem.

    Regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.