Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

poppler with mingw64 on windows?




  • Lifetime Qt Champion

    @Tomax63

    Well, then, have you followed the build instructions in https://github.com/freedesktop/poppler/blob/master/INSTALL ?



  • No, I haven´t.

    I tried, but get the following error:

    Der Befehl "cmake" ist entweder falsch geschrieben oder
    konnte nicht gefunden werden.
    

    Command "cmake" is either typed wrong or can not be found.


  • Lifetime Qt Champion

    @Tomax63 then install cmake, please.



  • Ok. I installed it.
    An error occurred:

    D:\dl\Dateien\Entwicklung\CPP\PumPpro\src\build>cmake ..
    -- Building for: Visual Studio 14 2015
    -- Selecting Windows SDK version  to target Windows 10.0.17134.
    -- The C compiler identification is MSVC 19.0.24210.0
    -- The CXX compiler identification is MSVC 19.0.24210.0
    -- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe
    -- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe
    -- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    CMake Error at CMakeLists.txt:47 (install):
      install TARGETS given no ARCHIVE DESTINATION for static library target
      "poppler-qt5".
    
    
    CMake Warning (dev) in CMakeLists.txt:
      No cmake_minimum_required command is present.  A line of code such as
    
        cmake_minimum_required(VERSION 3.13)
    
      should be added at the top of the file.  The version specified may be lower
      if you wish to support older CMake versions for this project.  For more
      information run "cmake --help-policy CMP0000".
    This warning is for project developers.  Use -Wno-dev to suppress it.
    
    -- Configuring incomplete, errors occurred!
    See also "D:/dl/Dateien/Entwicklung/CPP/PumPpro/src/build/CMakeFiles/CMakeOutput.log".
    

    When I added "cmake_minimum_required(VERSION 3.13)" to the top of the file, and started cmake again, the following appeared:

    D:\dl\Dateien\Entwicklung\CPP\PumPpro\src\build>cmake ..
    -- Building for: Visual Studio 14 2015
    -- Selecting Windows SDK version  to target Windows 10.0.17134.
    -- The C compiler identification is MSVC 19.0.24210.0
    -- The CXX compiler identification is MSVC 19.0.24210.0
    -- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe
    -- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe
    -- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/cl.exe -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    CMake Error at CMakeLists.txt:49 (install):
      install TARGETS given no ARCHIVE DESTINATION for static library target
      "poppler-qt5".
    
    
    -- Configuring incomplete, errors occurred!
    See also "D:/dl/Dateien/Entwicklung/CPP/PumPpro/src/build/CMakeFiles/CMakeOutput.log".
    

    In cmake GUI, it looks like this:
    ![alt text](0_1545417596883_Clipboard02.jpg image url)


  • Lifetime Qt Champion

    @Tomax63 I'm out here, never really used cmake.

    Just as note: it detected your MSVC compiler, you seemed to use MinGW for your project?



  • Yes, I do. I have no idea why it uses MSVC compile. I dont use it.



  • Does poppler work with MinGW?

    And how can I configure cmake to use MinGW?

    Or can I use gcc for poppler too?



  • Is it possible that someone who knows how to do it compiles the package for me and gives me the library (is it a dll?)

    Just like

    https://sourceforge.net/projects/poppler-qt5-mingw32/



  • @SGaist Could you help me by any chance?


  • Lifetime Qt Champion

    @Tomax63 Please give us some time to help you!

    People here help for free in their sparetime, and live in totally different time zones. Not everyone is using Windows, not everyone uses MinGW and not everyone CMake.

    Does this: https://stackoverflow.com/questions/4101456/running-cmake-on-windows bring you a step forward?



  • No problem, take your time all. I would just like to make it between christmas and new year


  • Lifetime Qt Champion

    Hi,

    Take a look at this stack overflow answer, the same applies to your case.

    Short version:
    You likely have something similar in the concerned CMakeLists.txt file:

    INSTALL(
      TARGETS poppler-qt5
      ARCHIVE DESTINATION lib # <-- A line like this is likely missing
      LIBRARY DESTINATION lib  
      COMPONENT library
    )
    


  • This is in my file:

    install(TARGETS poppler-qt5 
    		RUNTIME DESTINATION bin 
    		LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} 
    		ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
    
    


  • I think i really should stop trying - maybe one day I will find a compiled version.


  • Lifetime Qt Champion

    If it's the only thing that is giving trouble, just remove the ARCHIVE line and see if it behaves better.



  • D:\dl\Dateien\Entwicklung\CPP\PumPpro\src\build>mingw32-make .. -DCMAKE_CC_COMPILER=D:/Program Files/ingw-w64/x86_64-7.3.0-win32-seh-rt_v5-rev0/mingw64/bin/g++ -DCMAKE_CC_COMPILER=D:/Program Files/ingw-w64/x86_64-7.3.0-win32-seh-rt_v5-rev0/mingw64/bin/gcc
    mingw32-make (pid = 38832)
    mingw32-make is suspending for 30 seconds...done sleep(30). Continuing.
    mingw32-make: *** MAKE_CC_COMPILER=D:/Program: Invalid argument.  Stop.
    

    Now with this variation of CMakeLists.txt:

    install(TARGETS poppler-qt5 
    		RUNTIME DESTINATION bin 
    		LIBRARY DESTINATION lib)
    

  • Lifetime Qt Champion

    Is D:/Program Files/ingw-w64/ a valid path on your machine ?



  • Sorry, fault while inserting here.

    But I installed mingw anew in a shorter direcdtory tree and tried this:

    D:\dl\Dateien\Entwicklung\CPP\PumPpro\src\build>mingw32-make .. -DCMAKE_CC_COMPILER=D:/dl/mingw/mingw64/bin/g++.exe -DCMAKE_CC_COMPILER=D:/dl/mingw/mingw64/bin/gcc.exe
    mingw32-make (pid = 34784)
    mingw32-make is suspending for 30 seconds...done sleep(30). Continuing.
    mingw32-make: *** MAKE_CC_COMPILER=D:/dl/mingw/mingw64/bin/g++.exe: Invalid argument.  Stop.
    

    another try:

    D:\dl\Dateien\Entwicklung\CPP\PumPpro\src\build>mingw32-make .. -DCMAKE_CC_COMPILER=D:\\dl\\mingw\\mingw64\\bin\\g++ -DCMAKE_CC_COMPILER=D:\\dl\\mingw\\mingw64\\bin\\gcc
    mingw32-make (pid = 38848)
    mingw32-make is suspending for 30 seconds...done sleep(30). Continuing.
    mingw32-make: *** MAKE_CC_COMPILER=D:\\dl\\mingw\\mingw64\\bin\\g++: Invalid argument.  Stop.
    

  • Lifetime Qt Champion

    Why aren't you using the MinGW version provided with Qt ?
    Also, but only curiosity, why did you switch from Visua Studio to MinGW compiler ?



  • I used the mingw from my first steps with Qt.

    I dont know how to use the mingw within qt. I cant find the mingw32-make.

    It only has a qmake.exe

    Sorry - too many options, files and ways of doing it. I give up.

    Thanks for your help anyway!

    Thomas


Log in to reply