[Solved] App suddenly not showing in the main applications menu on N950



  • Hi all,

    While developing my app, all of a sudden, a week ago my application did not show up on the main applications menu anymore. I remember this has happened before, but usually after a restart of the phone, rebuild & run from QtCreator it started showing up again. This time however it didn't show up anymore, no matter what I tried. I am not an expert on debian packaging maybe I messed up some debian file in qtc_packaging/debian_harmattan?

    I run the app from QtCreator and it runs ok, it just doesn't show up in the apps menu.

    If I go in the phone in Settings->Applications->Manage applications, I can find my app, although with the generic Qt icon, not with the custom .png icon I provided.

    I tried removing the app and then dpkg -i appname.deb but this did not solve the issue. The app has all the entries inside /opt/appname, so I can run it from terminal on the phone.

    I also tried apt-get update :D although I really don't know what this command should do exactly...

    Any ideas, more cmd line magic?

    Thanks & regards,
    Ionut

    [EDIT: Alicemirror, set the thread to solved]



  • Did you have upgraded your Qt from 4.7.3 to 4.7.4 and reopened your project ?



  • Yes, I upgraded to the last version of Qt SDK/QtCreator;
    I'm running my app using this latest version.



  • well, I supposed :)

    As I have experienced is that the project does not run in a good way. This is - I suppose - due to that the previous version was building a wrong package with the issue of a non-singleinstance application (check a look to this page I wrote about it "here":http://developer.qt.nokia.com/wiki/Single_Instance_Harmattan_Applications)

    The best and faster way I have found to solve this problem is to create a new project from scratch and add the old sources, qml etc. As you can see there are few things that are changed in the virtual folder of the project, the qml organization tree and other changes. Including those related to the packaging files (i.e. .desktop, role etc.) that now works but seems incompatible with the old projects.



  • Hi Alicemirror,

    Your sugeestion worked, thanks !

    I created a new project in QtCreator with the same name, added the other files, and now the icon is shown in the app menu.

    Thanks,
    Ionut



  • I'm happy :) I have solved the same problem passing through a couple of new versions before :)



  • Cool thanks for this tip. I was just stung by the same issue.



  • @ZapB: just as when you illuminate me with your advices :D


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.