Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Port from 5.5 to 5.6



  • Hello All,
    I have an application that is built using Qt 5.5(msvc2013_64). Due to bugs in Qt 5.5 I want to migrate to advanced version. I don't know what changes should I make, I tried building and running the application with Qt 5.6.2(msvc2013_64), but the application crashes immediately and debug message in first line of main is not displayed. When I run the application outside Qt by clicking on the .exe in release folder I get the message "The procedure entry point ?wheelEvent@ListView@@ BLAH BLAH could not be located in the dynamic link lbrary G:\xyz\app.exe"
    I tried commenting the code section with wheelEvent, but no use.
    I don't know how to find the cause of this issue or get more information regarding the crash.
    The General Messages Tab displays : Project ERROR: Unknown module(s) in QT: multimedia.
    Thank You.


  • Lifetime Qt Champion

    Hi,

    How did you install Qt 5.6.2 ?
    How did you configure Qt Creator ?
    Did you reconfigure your project completely before building it ?



  • Can you clean the build directory and try again. Also clean all the moc files and object files. This may help.



  • @dhu0504 It Worked!
    I deleted the contents in Release and Debug directory and built the application. Added the required Qt dependency using windeployqt.exe and copied other dependency files. Now the application starts without crash and I'm able to debug.
    Thank you.


Log in to reply