To all the ambassadors that have the N950



  • Hello ambassadors, I relounch the note I've posted just now on Installation and development:

    http://developer.qt.nokia.com/forums/viewthread/9857/ => N950 Beta 2 OneClickFlasher.

    Please if you reflash your device post here notest and issues :)



  • Thanks for the heads up! I was just looking today for the twitter software and couldn't find it, so this is good news.

    Andrés



  • I have subscribed my twitter to all the technews of Nokia :)



  • OK, jumped in and did the flashing. Went without any problems on my Linux machine.

    Very nice new things. Just remember to enable developer mode to get all the dev utilities back, in Settings->Security. And don't forget to backup all your data. (I lost my shopping list =) )

    Andrés



  • Andrés reading the update documentation for the Beta 2 I have a doubt. Enabling developer mode from settings the components are uploaded automatically the first time you connect thte device via usb in sdk mode to the computer ? Or them should be uploaded separaterly ?



  • I actually didn't try connecting the device in sdk mode, but when you enable developer mode, a list will come up giving you the option to install each component group separately, so it's easy to get all the dev utilities back.

    Andrés



  • The developer mode you means the checkbok in settings / installations for install external applications not from ovi or another place? This will be setup after the reflash is done, is it true ?



  • Finally find the time to reflash, resinstall, reconfigure etc.
    It is a good new beta, with useful enhancements. Not yet tested in depth the web browser (before was always crashing) and some other features. Interesting the new settings in the application, twitter, new facebook and now accept mail account from @ovi.com



  • The browser now score 255 point in html5 test...



  • [quote author="AlterX" date="1316529093"]The browser now score 255 point in html5 test...[/quote]

    What is this ? Godd I suppose ?



  • [quote author="Alicemirror" date="1316530559"]
    What is this ? Godd I suppose ?[/quote]

    No: the previous Beta score 283!



  • Wonderful !!!

    But I see that it didn't crash so frequently as before...



  • From my point of view, in the previous one, only a few site sometimes had crashed.
    Anyway i think the final firmware contains all new features and so a much more score for the browser



  • @Alterx: how do you check the html5 scoring ?





  • Yes...html5test.com :-)



  • It is actually crashing much less for me (I hasn't crashed so far on sites where it used to), and I was surprised to find it even has flash.



  • I tried to flash my N950 with the Mac version of the OneClickFlasher of the link above. All I got was an error message:

    @
    $ ./Mac_OCF_34-2_EMMC_RM680-OEM1-916.bin

    This is OneClickFlasher for release 34-2

    • it will erase previous EMMC from the device
    • install the RM680 OEM image
    • install the EMMC RM680 content

    Extracting the archive from OneClickFlasher ...
    Extracting started at 19:26:54
    Extracting finished at 19:27:09

    Installing Flasher utility ...
    Running Installer

    Please make sure your device is properly powered OFF prior to
    connecting the USB cable.
    You can power your device off by holding down the power button
    for 8+ seconds.
    Flashing your device will erase all data and reset the device
    back to factory state.
    Please make sure you have backups of your data before proceeding
    with flashing.
    Depending on amount of data to be securely erased, the erasing may
    take as long as 30 minutes until the flashing starts.

    Please, be patient.

    Check first that device is powered OFF and then connect USB cable.

    Start with erasing previous eMMC ... 19:27:14

    flasher 3.12.0 (Jun 30 2011) Harmattan

    Picked ape-algo from a FIASCO file
    Suitable USB interface (bootloader/phonet) not found, waiting...
    USB device found at bus 36, device address 3.
    Device serial number is N/A
    Found device RM-680, hardware revision 1124
    NOLO version 2.0.31
    Version of 'sw-release': DFL61_HARMATTAN_1.2011.15-7_PR_RM680
    Sending ape-algo image (7020 kB)...
    100% (7020 of 7020 kB, avg. 31909 kB/s)
    Suitable USB interface (phonet) not found, waiting...
    USB device found at bus 36, device address 3.
    Device serial number is N/A
    Raw data transfer EP found at EP2.
    Ping attempt 1 (250 ms)
    Server application: 1.5.26
    Found product RM-680 rev. 1124
    Server implements softupd protocol version 1.8

    Battery level 95 %, continuing.
    Erasing, this may take a while.
    ERROR: Failed to erase MMC using 'secure' method
    @

    Did anyone have this problem?

    I double-checked the md5 sum of the file I downloaded. I followed the site's instructions to try to flash the device, and all I get is this error. Any suggestion?



  • Hi,
    I read with attention your log and it seems really identical to mine (I had to flash two different models with the first flasher and the with the beta 2 and I remember what's happen...)

    This piece of your log above only remember me a thing: the instruction says to launch the program that take a while to uncompress and start on the Mac - I have used a Mac too :) - then wait until the flasher shows the error that Suitable USB interface (phonet) not found, waiting....
    Only at this time you should connect the powered-off N950 to the Mac USB port. It self-power and - mostly - the flasher procedure starts etc.
    Initially I have tried to do this and I experienced two different behaviors. The first is something like yours (the program ends with a failure message) and the second is that the device is found and immediately after the flasher stops with a message that the device can't be flashed after the line Device serial number is N/A that seems a normal message.

    The only thing that I have done was - always following the flasher instructions - to try to reflash the device until all was done correctly.

    A note: my device flashed correctly only after the Mac was rebooted and this was the first operation with the computer, with no other devices connected to the USB i.e. printer, mouse etc. and with any virtual machine running on it.

    All the times that I have tried to flash a N950 with the Mac already working for normal operations I had problems and flash was impossible.

    Let me know if this can help you.



  • Hi Enrico!

    I tried your advices and I still can't flash the device, always getting the same error. I also tried with a PC running Linux and got the same thing:

    @# ./Linux_OCF_34-2_EMMC_RM680-OEM1-916.bin

    This is OneClickFlasher for release 34-2

    • it will erase previous EMMC from the device
    • install the RM680 OEM image
    • install the EMMC RM680 content

    Extracting the archive from OneClickFlasher ...
    Extracting started at 01:01:32
    Extracting finished at 01:02:07

    Running Installer

    Please make sure your device is properly powered OFF prior to
    connecting the USB cable.
    You can power your device off by holding down the power button
    for 8+ seconds.
    Flashing your device will erase all data and reset the device
    back to factory state.
    Please make sure you have backups of your data before proceeding
    with flashing.
    Depending on amount of data to be securely erased, the erasing may
    take as long as 30 minutes until the flashing starts.

    Please, be patient.

    Check first that device is powered OFF and then connect USB cable.

    Start with erasing previous eMMC ... 01:02:08

    flasher 3.12.0 (Jun 30 2011) Harmattan

    Picked ape-algo from a FIASCO file
    USB device found at bus 001, device address 026.
    Device identifier: 5A5541303331343139 (SN: ZUA031419)
    Raw data transfer EP found at EP2.
    Ping attempt 1 (250 ms)
    Server application: 1.5.26
    Found product RM-680 rev. 1124
    Server implements softupd protocol version 1.8

    Battery level 31 %, continuing.
    Erasing, this may take a while.
    ERROR: Failed to erase MMC using 'secure' method
    @

    I don't know what could be wrong. Any other tips? :(



  • To be honest, I don't think that something is worng. Not by your operation. The problem is that it's something of "magic" ...
    I can add a detail that I have forget before. When I started to update the beta 2 flashing it from the Mac I saw that the battery was about 70% full charged. And it got me problems. I tried more and more than I stopped and put the device in full-charge 100% of battery level. Then it run correctly.

    As a matter of fact I saw that your battery level is 31%
    I think that because of the reflashing is a hig power-consuming process - supposing due to the burining of the flash memory - please try to start flasing with higher charge, best with full-charged device. I remember that I have also tried with a low level battery (and this aspect IIRC is not mentioned anyway) and what happens was only a connection error. In theory I know that the usb will put the device in-charge when it is connected but this will be a special case for a lot of reasons.

    Thus, please try again (uff...) with a charged device and let us know what's happen. Then I have no more "advices" but we can invent something other... It seems that there are a lot of different behaviors with this procedure. What platform are you using? And what OS version?



  • Just flashed my N950 this morning. Every was Ok, I follow the instructions, did it in Windows. Coincidence or not just last night I was experience problems connecting to my wireless network. After the flash all was Ok. :)
    I forgot to save my photos... :D


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.