Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

What componnents are necessary to install?



  • Hi,
    I installed QT creator but i cant compile even the simplest qt widget app. That leads me to think that perhaps i didnt install other necessary components.

    what are the minimal necessary components to install?
    I should note that my goal is to create a widget application (C++).

    0_1538915041831_Screenshot from 2018-10-07 15-23-40.png



  • Hi,

    if you want to create applications, you also need to install Qt itself. From the screenshot you attached, Qt Creator, the integrated development environment, is the only component that is installed. You also want a version of Qt under the "Qt" category. I suggest you go with 5.11.2, or the 5.12.0 beta version if you are starting a new project. 5.12 is a long term support (LTS) release, expected before the end of the year, and as such a good choice for new projects.

    Best of luck creating your new applications!



  • Hi, also I think you need to do:
    sudo apt-get install libglu1-mesa-dev
    to be able to build your Qt programs properly.


  • Qt Champions 2019

    @YairBAR Install "Desktop gcc 64-bit".


Log in to reply