Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

MSVC2017 kit, could not find <QApplication> in debug mode, but profile and release are OK?



  • Hi, everyone.
    I'm a newbie , Installed QT 5.11, QT Creator 4.7.0. Then I tried to write a HelloWorld,kit MinGW works fine, then I switched to MSVC2017 kit, in debug mode it shows "<QApplication>: No such file or directory", but when I changed it to profile mode or release mode, It worked fine , so what happened?

    pro file:
    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
    QT += core gui widgets

    SOURCES +=
    main.cpp

    and the main.cpp file:
    #include <QApplication>
    #include <QDialog>
    #include <QLabel>

    int main(int argc, char *argv[])
    {
    QApplication app(argc,argv);
    QDialog w;
    QLabel label(&w);
    label.setText("1");
    w.show();
    return app.exec();
    }


  • Qt Champions 2019

    @Jerry.Wilson You didn't mention whether you installed Qt for MSVC2017, did you? After switching to a different Kit you should do a complete rebuild (in case of errors delete the build directory, run qmake and build).



  • @jsulm Thank you for replying, I installed QT for MSVC2017, and I did "Clean all" then rebuilt the project after switched to MSVC2017 kit that time.

    But just a moment ago after lunch I restart the QT Creator. the problem disappeared just like it never happened...

    Thanks again and sorry for my poor English.


  • Qt Champions 2019

    @Jerry.Wilson Strange, don't know what it was, bud glad it works now!



  • @jsulm Maybe the Creator was hungry ...::P


Log in to reply