Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

module "QtQuick.Enterprise.Controls" is not installed



  • I use Windows 10 & have installed the online Commercial software, where I also installed the Qt Enterprise Add Ons. Now I am trying to run an example which has to import QtQuick.Enterprise.Controls 1.3. But it gets underlined in red and displays QML Module not found. What should I do to compile my program ? plz help


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Might be a silly question but did you build and install the module ?


  • Moderators

    Qt Quick Enterprise Controls were merged into Qt Quick Controls after 5.7 or so, so you might just need to change your example to use QtQuick.Controls 1.4 instead and that might be enough to get it working.



  • 0_1536639500492_1.png
    This is what it shows.



  • @SGaist This module was installed along with all the tools and other qml modules through the commercial edition download .exe file. So no, I didn't build and install this module separately.



  • Installed the latest Qt 5.12 and all the Enterprise Add-ons and Controls.

    Tried to run the Gallery example that showcases all the Enterprise Controls.

    Example does not run. Same error as the OP.

    What gives? As a licensed commercial user, shouldn't you be able to run an example and actually have an expectation that it will work?

    Tried the change Enterprise to to just QtQuick.Controls 1.4 and no joy..still does not run.

    Some of the Controls are undefined..like "Dial"..even though the Dial.qml file exists in the Enterprise folder. Should the Dial.qml and other undefined Enterprise controls just be moved to another directory/folder?

    This is on a new, clean Mac if that matters.


  • Lifetime Qt Champion

    Hi,

    Might be a silly question but did you first build and install the module before building the examples ?



  • @SGaist

    I downloaded through the Qt Account portal..

    Unified Qt online installer for macOS

    Installed everything. The Enterprise Controls were all "checked" for installation. The Enterprise Controls are in their folders. The QML for the controls are all there.

    Was there an additional step I missed?


  • Qt Champions 2018

    As a licensed commercial user, you can ask the commercial support.

    Feel free to post the answer back here to inform other users looking at this post later.



  • So I dug deeper into the Downloads page and found..

    qt-enterprise-mac-x64-5.12.0.dmg

    Surprisingly, there are no "Enterprise Controls"in this install..but the Gallery Example that showcases them works fine.

    ??Confused??

    It appears though AndyS is correct in that the Enterprise Controls have just been merged into Qt Quick Controls. IDK.

    It would sure be nice if the "Unified Qt online installer for macOS" were updated to reflect those changes...


  • Lifetime Qt Champion

    I used the maintenance tool to install them on macOS. However, that was a source install. Therefore, I built and install the module and everything worked as expected.


Log in to reply