Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to add the QWebView?



  • I have QT5.5.0 version and i am trying to add the QWebView in my application and added the QT += qtwebkitwidgets/QT += webkitwidgets in my .pro file and i gave build then i got this error:

    Warnings while parsing QML type information of C:/Qt/Qt5.5.0/5.5/mingw492_32/qml:
    <dump of C:\Qt\Qt5.5.0\5.5\mingw492_32\qml>:1:24: Reading only version 1.1 parts.
    <dump of C:\Qt\Qt5.5.0\5.5\mingw492_32\qml>:10:5: Expected only Component and ModuleApi object definitions.

    Project ERROR: Unknown module(s) in QT: webenginewidgets
    Project ERROR: Unknown module(s) in QT: webenginewidgets
    Project ERROR: Unknown module(s) in QT: webenginewidgets
    Project ERROR: Unknown module(s) in QT: qtwebkitwidgets

    So What should i do for this?


  • Lifetime Qt Champion

    Hi,

    Short answer: change your compiler. QtWebEngine can only be built with Visual Studio. That’s not a Qt limitation but comes from the Chromium engine used underneath.


Log in to reply