Can't install Qt SDK

  • I'm getting the following error:

    Error during installation process (
    The collection file '/Users/agnar/.config/Nokia/qtcreator/helpcollection.qhc' is not set up yet!

    I've tried installing both from online and offline installer, and both to /Users/<user>/QtSDK and to /Developer/SDKs/QtSDK, but nothing helps. (I prefer the latter location).

    What's wrong?

  • Have you enough space on disk?

  • Absolutely: 200Gb

  • Well... seems like install app error, Try select "Custom" install mode and uncheck Documentation->Nokia MeeGo API Doxumentation item, or all Documentation item.

  • There is a ~/.config/Nokia/qtcreator/ directory on my disk. I don't know when it was created, and who created it. All directories (from .config and down) has owner "root" and group "staff" and is no writable to anyone else than owner.

    I fixed the write permissions of this directories but ran into other problems:

  • First, the installer was unable to run the .../QtSDK/Madde/postinstall/ script.

    Running it from command line as root went fine (at least no errors).

    Then this came up:

    Error during installation process
    The output of
    /Developer/SDKs/QtSDK/Simulator/Qt/gcc/bin/qmake -query
    is not parsable. Please file a bugrerport with this dialog
    output: ""

    Comes a lot of times during install, Pressing [Ignore] on all of them makes the installer complete eventually.

  • That "known bug" is close since "it can not be reproduced", unfortunately.

    I met the same problem yesterday... and solved it today. If your .config/Nokia directory is created by root, delete it. Run the installer again, then you will see a new .config/Nokia directory created by you. Just continue your installation and it should work.

  • I have the same problem, on whatever linus distribution i install qt creator.
    I can definitly reproduce it.

    since i want to program for maemo nokia n900 i need het hamattan part.
    i found that when you run the by hand
    you get the error thet it can not find file
    and that is correct is does not exit
    the file that exit is

    could this be the problem ?

    does anyone was able to instal de QTSDK in total on an debian linux system
    whitout any probelm ?


  • I have a problem relationed with arm-2009q3-67-arm-none-linux-gnueabi-x86_64-unknown-linux-gnu.tbz, when I try to uninstalls Qt SDK, the uninstaller assistent show a progress bar, when is deleting (arm-1009q3 ...) the process "pause" and don't continuous.


Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.