Important: Please read the Qt Code of Conduct -

Qt application on beagleboard xm

  • We have build an application on host system (linux Qt creator) and copy all lib's to board(BB xm) it runs the application but shows two cursors one for system and one for application.

    Why this is happening. (i thin it runs as a seprate system than OS GUI).

  • Do you use the X11 version or the Embedded version of Qt on BeagleBoard?

    The repository of Ångström Distribution (the default operating system on BeagleBoard) has both. The X11 version uses the desktop environment of the OS, while the Embedded version directly draws the GUI to the frame buffer, and reads mouse movements directly. If you use the Embedded version without turning the DE of the OS off, you will see this kind of things happen.

    If this is the case, you should either use the X11 version of Qt instead, or turn off X before you launch the application (from command line).

  • how to turn off this x?

    as you told i just checked , but when i run prebuild examples of qt for bb-xm then there is no problem regarding cursor on same os.

  • Hi

    i have installed qt creator on host machine (VMware Ubuntu)-virual linux.
    and installed cross compiler for my target board(BB-xm) arm-cortex -a8.
    and build qt library for target machine with following configuration-

    1)./configure -prefix /opt/qt_arm_texax_4.7.3 -embedded arm -platform /qws/linux-x86-g++ -xplatform /qws/linux-DM3730-g++ -depths 16,24,32 -qt-mouse-pc -qt-mouse-linuxtp
    -qt-mouse-linuxinput -plugin-mouse-linuxtp -plugin-mouse-pc

    2)./configure -opensource -confirm-license -prefix /opt/qt-arm -no-qt3support -embedded arm -little-endian -xplatform qws/linux-DM3730-g++ -qtlibinfix E

    i have successfully create build and deployed on target.
    but problem is that it shows two cursors on system one for qt app and one for os.
    even though if i compiled sample codes there are two cursors.

    is my configuration wrong?
    or is any other problem, please tell me what can i do to get solution of this problem.

    OS : angstrom
    H/W: beagleboard-xm
    kernel: 2.6.32
    Qt creator version -2.2.1
    Qt lib version-4.7.3

    Nilesh Mane

  • I ve the same problem of double cursor.. Pls if sumbody know the solution,post the rply.. Urgently needed..

  • I think you should download a "console only" Narcissus image to solve the problem.

    I started write a wiki (that I haven't terminated) but the written part describe how to download the image:

  • I'm tryin to run a cross compiled qt application in beagle board with ubuntu os.. But i'm getting double cursor when running the app(one in qt app and another in desktop).. So kindly tel me a solution for this..

  • Downloading console only image is not the solution its an temporary option for testing (because if i want to deploy the other operation systems like angstrom there is same problem) and i need the qt application with the desktop version of Ubuntu.

  • Nope.. Nt yet solved

  • Am using an ARM 9 based board running debian linux. I have compiled a Qt application and deployed it on the board. When i run the application two cursors appear . The Qt cursor runs fine but the default cursor also appears which tends to wipe out the Qt application exposing the background desktop.
    Can someone please guide me how to disable the default mouse or provide a solution to this problem . I need to get rid of the default mouse.

  • HI

    I am new to QT and programming. I am working on a project to build a windows interface. supposing I have a basic window with minimal functionality. How do I go about loading the window to a beagle board? Appreciate any help you can give.

  • am also facing same scenario when i deploy my Qt app into beaglexM board...
    Showing two mouse pointers one for Qt app & one for OS.
    Also after loading nd running my Qt App in my board, QT GUI is behaving with mouse clicks but at same time it is wiping out my OS GUI.
    Pls assist me ...

Log in to reply