Widgets rendered incorrectly on some Systems



  • I have built a Qt gui and it is displayed correctly on my machine. However on some other computers, as well as in virtual machines, several widgets are not rendered correctly. For example the marks inside the QCheckBoxes are not displayed.
    I am using Qt 5.10 with Visual Studio 2017. I have downloaded the prebuilt binaries.

    I was using Qt 5.4 with Visual Studio 2012 before and it worked fine, what can be the reason for the problems with this version?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you check the differences between these machines and yours ?



  • Hi.
    It has so far not worked in any VM that I set up (Virtual Box, Windows 10) I have tried to replicate my host system as closely as possible inside the VM, installed all the same Visual C versions, even installed Qt and Visual Studio because I thought they might install some updated versions of some required DLLs or so, but it didn't work.

    One of my friends who tested my software has onboard graphics, while I have a dedicated NVidia GPU.

    I suspect that it has something to do with the GPU at this point, because afaik the VM uses software rendering and my friend has onboard graphics, but I am not sure.


  • Lifetime Qt Champion

    Can you check if you have the same situation with Qt 5.9 and 5.11 ?



  • I have checked it with 5.11, had the same problem.
    Now with 5.9 it works in my VM, will test on more systems but probably it will be ok, if not I will post again in a few days.


  • Lifetime Qt Champion

    Then there might have been a regression. You should check the bug report system to see if there's anything related to QCheckBox recently.


  • Qt Champions 2018

    There were some issued with MacOS and QCheckBox in 5.11 but I'm not aware of any other problems atm. Can you please provide a small example for this issue?



  • After switching to Qt 5.9 the problem was solved on the machines of some of my customers, but now others are experiencing the same problem.
    It works correctly on most PCs, the problem only happens on some computers and I can not reproduce it on my machine, nor do I have access to those computers. I wrote the software for Windows, most of my clients use Windows 10. The following image shows the GUI on a client's PC. The mark in the radio buttons is not rendered and some of the checkboxes are actually checked.

    https://imgur.com/a/JE1kZaX

    I was thinking that it might have something to do with incompatible runtime libraries or something like that, would that make sense?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.