QT-Ceator with intel compiler on Windows



  • Hi,

    i'm trying to use the intel compiler with the QtCreator on a windows machine. I have build qt 4.8.7 with the intel compiler over the command line and it also gets detected properly in my QtCreator.
    I added a custom compiler according to http://doc.qt.io/qtcreator/creator-tool-chains.html#adding-custom-compilers ( there is a option to add a ICC compiler on Linux but not on windows) with the following settings: 0_1531229535515_464b695d-a9d4-4b01-9880-615eff1f6f8d-image.png

    Then i added a new kit with the created compiler and the qt-intel build, but there i get the following error:
    0_1531229923792_4382d1b8-670d-45bf-b816-853de7eb1ade-image.png

    The environment variables for the intel compiler should be set correctly. What am i doing wrong or do i miss something important?

    Thanks for the help,
    Felix


  • Qt Champions 2017

    @FGin said in QT-Ceator with intel compiler on Windows:

    The environment variables for the intel compiler should be set correctly.

    The ABI signature does not seem correctly configured it says x86, when it should be amd64 (judging by the compiler's path) and it says msvc2013, which is not intel ... in any case I might be wrong, but still the ABI signature of the compiler doesn't match the one for the Qt library, which is why you get the error.



  • @kshegunov thanks for the reply,

    the Problem is i don't have the correct options in the drop down menus to configure the ABI signature of the compiler correctly. Are there other ways to configure it? Is it possible that the ABI signature of the Qt library isn't detected correctly, because i build it with the intel compiler and here it says msvc2013? If i configure the compiler with the same ABI as my library i can get rid of the error but i'm running then immediately into this error:
    The process "C:\Qt\qt-4.8.7\qt-everywhere-opensource-src-4.8.7\bin\qmake.exe" exited with code 1.
    Error while building/deploying project (kit: intel)
    When executing step "Make"

    Thanks,
    Felix


  • Qt Champions 2017

    @FGin said in QT-Ceator with intel compiler on Windows:

    the Problem is i don't have the correct options in the drop down menus to configure the ABI signature of the compiler correctly.

    How so?

    Are there other ways to configure it?

    Not that I'm aware of.

    Is it possible that the ABI signature of the Qt library isn't detected correctly, because i build it with the intel compiler and here it says msvc2013?

    Maybe, but rather improbable.

    If i configure the compiler with the same ABI as my library i can get rid of the error but i'm running then immediately into this error

    Run qmake with -d or -d -d and inspect the debug log.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.