QtCreator 2.3.0 + Qt 4.7.4



  • И снова здрасьте :)

    Поставил сегодня QtCreator 2.3.0 + Qt 4.7.4. И теперь вообще не могу скомпилировать ни один проект. Вот пример того, что будет, если попытаюсь: http://s1.ipicture.ru/uploads/20110906/TJ1BV2bw.jpg Когда жму остановить, то пишет "Программа неожиданно завершилась." с кодом 62097. Подумал, что может из-за русского интерфейса кодировка не понятная, поставил английский, но все равно. Иногда, когда пытаюсь ту ересь на не понятной кодировке скопировать, то IDE вообще падает О_о

    Еще проблема с документацией в самой Qt, вот: http://s1.ipicture.ru/uploads/20110906/CA1s4R69.jpg Так же и в Асистенсе: http://s2.ipicture.ru/uploads/20110906/7excz1DJ.jpg

    QtCreator и либы качал отдельно, не через SDK. OS Windows 7 SP1. Я сначала подумал, что это из-за какого-то конфликта версия (удалял и новые ставил уже много раз), почистил систему вообще от всего, что связано с Qt, но все равно.

    Может кто-то сказать, что это за чудище случилось? Если это такой баг, то может кто-то написать баграпорт (если уже не написан)?

    З.Ы И небольшой вопрос: не понравилось, что теперь по дефолту в папку сборки пишет версию Qt (например untitled-build-desktop-Qt_4_7_4________). Можно конечно в проекте переписать имя, но постоянно это делать не удобно. Можно как-то поменять дефолтный шаблон этого имени?



  • Блин таже фигня!

    Обновился до 4.7.4 и теперь перестала работать отладка C++
    брейкпоинты не работают!
    Когда отключаю отладку QML, при запуске отладчика начинает на это ругаться и не дает запустить проект!

    Пропал стартовый экран со списком проектов-примеров.

    Одни негативные эмоции это этого релиза!



  • Кто-то ставил SDK, там так же?



  • Ну Qt SDK и ставил. Через онлайн инсталлер.
    он собственно и ставит QtCreator 2.3.0 + Qt 4.7.4

    P.s.
    Ктоб подсказал как вернуться назад к рабочей версии Qt?



  • Хе. Я специально для этого оставляю бекапы инсталов старых. На авось (как сейчас). А, к тому же увидел, что в Qt SDK online есть же выбор, чтобы скачать 4.7.3, может с ними будет нормально? Попробуйте, отпишитесь :)



  • Проблема только в тех проектах которые уже раньше компилились под старый Qt? И кстати какой компайлер?



  • [quote author="Aleksei Mikhailichenko" date="1315331746"]Проблема только в тех проектах которые уже раньше компилились под старый Qt? И кстати какой компайлер?[/quote]
    Нет проблема во всех..
    Можно просто визардом создать Qt Quick Application
    и попробовать поставить бряк в main.cpp

    Собираю дефолтовым компилером MinGW



  • Вообщем скачал отсюда ftp://ftp.qt.nokia.com/qtsdk/
    Qt_SDK_Win_offline_v1_1_2_en.exe

    Все работает как часы.
    Вот жешь вражины! Целый день на этот шит убил :(



  • [quote author="Aleksei Mikhailichenko" date="1315331746"]Проблема только в тех проектах которые уже раньше компилились под старый Qt? И кстати какой компайлер?[/quote]

    Все так же, как и у CodeDaemon.

    [quote author="CodeDaemon" date="1315337603"]Вообщем скачал отсюда ftp://ftp.qt.nokia.com/qtsdk/
    Qt_SDK_Win_offline_v1_1_2_en.exe[/quote]

    Пасиб за совет, позже попробую.



  • Try using VirtualBox. You can keep old/new version without mutual influence. Helped me very much.



  • [quote author="Fomand" date="1315385325"]Try using VirtualBox. You can keep old/new version without mutual influence. Helped me very much.[/quote]
    Good idea! But too late :)

    I didn't expect that such epic fail, can happen with Qt.



  • Поставил офлайновый SDK, теперь документация нормально отображается (хотя новая главная страница ужасна), но проекты все равно не компилируются, все та же ерунда на не понятной кодировке. Для интереса поставил QtCreator 2.3.0 + Qt 4.7.3, тоже такая же фигня.
    Поставил QtCreator 2.2.1 + Qt 4.7.4, работает, хотя тогда криво отображается документация (придется через сайт смотреть).



  • Скачал новый QtCreator 2.3.1. Этот уже таки компилирует, но вот почему он игнорирует флаг "CONFIG += console"?.. Ну, точнее если запускать через IDE консольное приложение, то окно консоли не появится.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.