Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Creating AVD



  • Hi,
    I have tried to create an AVD using Qt > Options > Devices > AVD Manager tab Add button.
    I went through all the available ABIs with target API android-25. Every time I got the following message:
    Exception in thread main java.long.NoClassDef Found Error: javax/xml/bind/annotation/XmlSchema.
    I am wondering how can I fix this.
    Thank you.



  • @gabor53 What version of the Java JDK and JRE have you installed? The only one I've been able to get working is JDK version 8 - I've tried the later versions but they also fail with a similar error to what you are seeing. I did manage to get rid of this error but there are issues elsewhere.

    To solve your error, open up the advmanager.bat file using a text editor (not Notepad) and paste the following into the file:

    if "%OS%"=="Windows_NT" setlocal
    
    set DIRNAME=%~dp0
    if "%DIRNAME%" == "" set DIRNAME=.
    set APP_BASE_NAME=%~n0
    set APP_HOME=%DIRNAME%..
    
    // #### ADD THIS LINE HERE ####
    set JAVA_OPTS=-XX:+IgnoreUnrecognizedVMOptions --add-modules java.se.ee
    // ####
    
    @rem Add default JVM options here. You can also use JAVA_OPTS and AVDMANAGER_OPTS to pass JVM options to this script.
    set DEFAULT_JVM_OPTS="-Dcom.android.sdkmanager.toolsdir=%~dp0\.."
    
    @rem Find java.exe
    if defined JAVA_HOME goto findJavaFromJavaHome
    

    Try running the ADV Manager again from within QtCreator.


Log in to reply