Add to version control not working in Qt Creator 2.3.0?



  • Hi, I just upgraded to Qt Creator 2.3.0 on a Ubuntu system, and suddenly I no longer get the possibility to add new projects to SVN when creating them from QtCreator. This has always worked fine before, but now I can only add classes (cpp/h-files) to an existing project. When I create a new project, the "Add to version control" menu only has the <none> option.

    Anyone else seen this problem, and know how to fix it?

    Cheers



  • Yes, it worked for me when I set the version control using the Manage option. Otherwise it showed only <none> option.


  • Moderators

    We started to ignore unconfigured version control systems in Qt Creator 2.3. Those will not work anyway (e.g. since the executable we need is not found).

    Note that most should work with the default settings.



  • Hi and thanks for the replies. It didn't work for me even with the Manage option.

    My SVN is correctly configured, I can use it to update and commit from within Qt Creator, I am also able to add cpp/h-files to existing projects from the "new" menu. It just doesn't work for new projects, even if these projects are subdirectories of existing projects. This used to work earlier.

    Another think on the subject of version control. I would really like to be able to commit/update from the context menu in the projects pane. An option to customize the context menu would be perfect!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.