Important: Please read the Qt Code of Conduct -

error: [install_target] Error 129

  • Hello,
    I`m trying to configure QT for android for days, and i dont still have any luck.
    I've installed NDK and android studio. Then installed SDK and configured tools->devices as shown in tutorials. It says java settings are OK and android settings are OK. (SDK 26.1, NDK:17&10e)

    But after build, it gives this error:
    :-1: error: [install_target] Error 129
    And this is the output

    22:05:28: Configuration unchanged, skipping qmake step.
    22:05:28: Starting: "C:\Users\p855\Downloads\android-ndk-r10e-windows-x86_64\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe" 
    make: Nothing to be done for `first'.
    22:05:30: The process "C:\Users\p855\Downloads\android-ndk-r10e-windows-x86_64\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe" exited normally.
    22:05:30: Starting: "C:\Users\p855\Downloads\android-ndk-r10e-windows-x86_64\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe" "INSTALL_ROOT=C:/Users/p855/Documents/build-untitled5-Android_for_armeabi_v7a_GCC_4_9_Qt_5_10_1_for_Android_armv72-Debug/android-build" install
          0 [main] sh 4428 sync_with_child: child 1908(0x1EC) died before initialization with status code 0xC0000142
         21 [main] sh 4428 sync_with_child: *** child state waiting for longjmp
    /usr/bin/sh: fork: Resource temporarily unavailable
    make: *** [install_target] Error 129
    22:05:31: The process "C:\Users\p855\Downloads\android-ndk-r10e-windows-x86_64\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe" exited with code 2.
    Error while building/deploying project untitled5 (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.10.1 for Android armv72))
    When executing step "Copy application data"
    22:05:31: Elapsed time: 00:02. 

    I'm using Win 10. Tried different QT (5.9 & 5.11 ) and NDK (17 & 10) versions.
    What should i do, any idea?

  • Notice the "/usr/bin/sh". For some reason the build system thinks you are running on Linux. This is an old bug and has at least once been a cause for problems in this forum too. I vaguely recall that the problem is some other application in Windows's PATH that fools the build - but I don't remember what application that is. Try googling and I'm sure you'll find relevant info.

  • Thank you @mvuori for your comment.
    For people facing with this problem: I havent find the solution. I have found and tried the suggestions from google but didnt work. Then installed QT to another computer. That`s how i solved the problem.

  • for Qt 5.10.1 use SDK Version: 25.2.5, NDK Version: 10.4.0 it worked for me

Log in to reply