⚠️ Forum Maintenance: Feb 6th, 8am - 14pm (UTC+2)

[SOLVED] Unable to install Qt 5.8

  • I've been trying to install Qt 5.8 for the past 2 hours and I'm having no success at all. I'm on Windows 10 x86 and what I've tried is

    Downloading the offline installer - Cannot get pass the login screen because everytime I try to login it gives me the error "SSL handshake failed"
    Downling the online installer - Cannot proceed past the next button because it always says "Failed to connect to server. Check your network connection and try again". I tried changing the mirrors using the QtSdkRepository folder but with every mirror I tried, it always gave the same error.
    Downloading from source and build - I've tried to do this too but I'm having trouble getting the basic build steps to work and I'd really want to avoid building from source.

    I'm getting fed up that the offline installer is broken and won't let me login. I've searched the forums for this problem but I can't find a windows solution for the SSL handshake error. Does anyone have any ideas about what I should do?

    Help much appreciated

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Are you trying to use the commercial version of Qt ? If not, then skip the login screen and continue installing.
    Otherwise, are you doing that installation in a particular network ? (e.g. enterprise network, through a proxy, etc)

    What version of the installer are you using ?

  • @SGaist Hi

    Yes I'm trying to use the commercial version of Qt. I'm not really sure what you mean but how I obtained the installer was logging into my qt account and select ing Qt , 5.80 and downloading the file qt-enterprise-windows-x86-msvc2013-5.8.0.exe.

  • Lifetime Qt Champion

    Can you check with the latest online installer ?
    It gives you also access to older versions of Qt.

  • Lifetime Qt Champion

    hi @Cake,

    and just to add to @SGaist, if you are not limited to 5.8, you should better use 5.9.x, which is still supported.


  • @aha_1980 @SGaist
    I solved the problem by building again from source which took a very long time.
    Thanks for the help :)

Log in to reply