Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error when executing step "Make"



  • I am running on Ubuntu 16.04.2 LTS with QT 5.5.1. I upgraded everything on the board that I'm working on (Nitrogen 6) and I'm not sure if it upgraded something that is no longer compatible. This is the error I am getting. I looked at other forums that mentioned installing g++ or g++-5, but none of that works.

    14:58:36: Running steps for project Hello_World...
    14:58:36: Configuration unchanged, skipping qmake step.
    14:58:36: Starting "/usr/bin/make"
    /usr/lib/distcc/bin/g++-5 -c -pipe -g -mfloat -abi=hard -march=armv7-a -mfpu=vfpv3-d16 -DLINUX -Wall -W -fPIC -I../Hello_World -I. -isystem/usr/include -isystem /usr/include/arm-linux-gnueabihf -I/usr/lib/arm-linux-gnueabihf/qt5/mkspecs/linux-g++ -o main.o ../Hello_World/main.cpp
    make: /usr/lib/distcc/bin/g++-5: Command not found
    Makefile:278: recipe for target 'main.o' failed
    make*** [main.o] Error 127
    14:58:36 The process "/usr/bin/make" exited with code 2.
    Error while building deploying project Hello_World (kit: GccKit)
    When executing step "Make"

    Also, when I run it from the terminal, I get this warning:
    Warning: EGL sugggested using X Visual ID ee (RGB888) for EGL config 1 (RGB444),
    but this is incompatible

    Anybody have any ideas?


  • Lifetime Qt Champion

    Hi @user614,

    /usr/lib/distcc/bin/g++-5

    Seems you have set up somewhere to use distributed compiling with distcc.

    Is this intended? Seems like the distcc compiler is not installed. Please check your Kit settings in Tools -> Options which compiler is selected.

    Regards



  • I have GCC as my compiler. The path is /usr/lib/distcc/g++
    and I DO have distcc compiler downloaded to my system. I'm not sure why it's giving me that error.


  • Lifetime Qt Champion

    Hi,

    If you're not using distcc currently, you should maybe uninstall it and try to build again. Or at least check whether there's anything configured for it.



  • @SGaist
    So I got it to work, but only because I went to the make file and changed the CXX directory to the appropriate directory of g++-5. This is a temporary fix, but how do I make sure that the other files do not have that directory when it makes a make file?


  • Lifetime Qt Champion

    Is it in your PATH environment variable ?


Log in to reply