OpenGL support with Qt on Tegra2



  • Hi! Anyone who tried Qt on Tegra2 recently? I've been working with Qt on Tegra2 for some months until some months ago. I had to change something in Qt sources but after that everything was OK.

    Now Linux for Tegra has been updated, and I'm starting again to work on this platform: I found out Qt code rendered using the OpenGL paint engine is not working correctly. I tried a test application I wrote months ago (it was working), and now it is all rendered incorrectly. Background is always painted black, png are rendered incorrectly etc...

    Anyone working on Tegra2 at the moment with a recent Linux for Tegra? Can you confirm everything is working OK or are you having issues as well?

    Thanks!



  • I have only tried using the android-Qt port and without opengl so thats probably not much help



  • Problem is just related to OpenGL. The rest seems to be working correctly.



  • Do pure opengl applications work correctly?



  • I know 24 bit depth has a segfault which is anyway "documented". hellogl_es2 sample seems to be working correctly.

    I have a simple application written in Qt rendered in OpenGL which was working on Tegra2 very good until some months ago. Works also on other platforms. Now I'm testing it again on the new Linux for Tegra (Tegra2) and it is not working even at 16 bit with Qt 4.7.2.

    Just wanted to know if anyone else experienced the same: a different in the OpenGL libraries on the new Linux for Tegra. Because otherwise it may mean I have done something wrong or that the board I'm working on has something wrong (I didn't install the system myself).

    Thanks for your answers.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.