[Solved] Qt SDK 1.1.3 with Qt Libs 4.7.4 -- 64 bit only?



  • Is there a pre-built Qt Lib 4.7.4 for OSX? or is it just shipped with 64 bit, as implied by the file name "Qt_SDK_Mac64_offline_v1_1_3_en"



  • It seems I don't have a 32 bit GCC choice in my tools-chain. That's why I think I may not have the 32 bit libraries for 4.7.4 -- Where can I get them? is there any extra Qt-Creator setting change I need to do before I can use them?



  • I cannot choose 32 bit.

    I installed from the 1Gig installed on the Qt website, then installed both of these:

    Cocoa: Mac binary package for Mac OS X 10.5 - 10.6 (32-bit and 64-bit)
    http://get.qt.nokia.com/qt/source/qt-mac-opensource-4.7.4.dmg (211 MB, includes build and interface tools)
    http://get.qt.nokia.com/qt/source/qt-mac-opensource-4.7.4-debug-libs.dmg (721 MB, libs only)

    Still no good. I cannot see any 32-bit compilers available. just 64 bit.

    What am I doing wrong?


  • Moderators

    Merged the two threads. Please don't double post.



  • Sorry about the double post.

    can anyone please help? I've been at this since yesterday. I can't get any work done. Why am I only seeing 64 bit build options although my machine has 32 bit GCC and I downloaded and installed everything 4.7.4 off of QT's website?



  • It's very likely that the prebuilt binaries only contain 64bit versions of Qt. I'm afraid, but I would say that you will have to compile Qt yourself. It's not a big deal, and with a decent machine it will last some 30 minutes.

    As for the gcc 32/64bit: The compilers shipped by Apple are able to generate 32 and 64 bit code for both Intel and PPC architecture. Everything's just a matter of some switches to the compiler's and linker's command line.



  • thanks. that resolved it.



  • How did you resolve it? Could you use the 32 bits toolchain? I have the same problem too. I have a project that uses some libs in 32 bit versions only, and although I can see the 32 bit toolchain on the Qt creator settings, I can't choose them on the project.

    How did you do it? Did you have to build Qt again? In that case how did you do it?



  • There is no separate 32bit/64bit toolchain on the Mac. The toolchains differ only in compiler versions (gcc 4.0, 4.2, clang). All of them support 32bit/64bit and PowerPC/Intel object code simultaneously.

    You will have to set the appropriate combination by command line switches to gcc or in the .pro file for qmake:

    To build only 32bit targets use:

    @
    CONFIG += x86 ppc
    CONFIG -= x86_64 ppc64
    @

    You can link your application against every lib that includes object code for the same architectures. It does not harm if you libs contain more architectures than you need.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.