Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Unable to find the platform plugin



  • Hello,
    I'm in the process of deploying my first Qt application, which works in QtCreator in release mode. I have tried creating a new directory with the release executable in it and moving all the necessary dll files to that directory. I receive the error "The application was unable to start correctly (0xc000007b)."

    After that approach failed, I tried to use windeployqt. What I get is the error "Unable to find the platform plugin" (which should be qwindows.dll, which is in the correct location [Qt>5.10.1>mingw53_32>plugins>platforms], if I'm correct). When I google the issue, I only find an issue with mixing up release and debug versions, and my windeployqt is finding the correct release version:

    0_1527811073192_qterr.png

    I believe this might be an issue with my mingw version being 32 bit but my qt version and application are 64 bit. I've seen some talk of environment variables, but I'm not sure what to do here.

    Some additional details: I'm using a cygwin terminal, and I'm not sure if my version of QtCreator is the same as my version of Qt, if that matters.

    Thanks



  • I'm going to mark this as solved because I believe I've tracked down the issue to one of my dependencies, quazip, which a lot of other people seem to have trouble deploying with. If anyone has any experience with deploying a qt application with quazip, I welcome it.


Log in to reply