[solved] QProcess with gnome-terminal



  • Hello Comunity,

    this is my first post here. I have some problems with the gnome-terminal while using the qprocess.

    @ QString program = "gnome-terminal";
    QStringList arguments;
    arguments << "bash --rcfile /opt/.bashrc-OpenFOAM";

    QProcess *proc = new QProcess(this);
    proc->start(program, arguments);@
    

    The terminal starts but the rcfile does not load. Is there something I am doing wrong?

    Thanks for the help.
    Martin


  • Moderators

    Welcome to the forum!

    Does using @ arguments << "bash" << "--rcfile" << "/opt/.bashrc-OpenFOAM"; @ make a difference?



  • thanks for the fast reply but unfortunately it isnt working.

    "problems while reading arguments"



  • nobody any advice? I need/want this :(



  • [quote author="wernsen" date="1314818174"]"problems while reading arguments" [/quote]

    Is this Qt, gnome-terminal or bash output?



  • Try:
    @arguments << "-x" << "bash" << "--rcfile" << "/opt/.bashrc-OpenFOAM";@

    Note: I would try on a command line first to ensure the gnome-terminal syntax is correct and works appropriately.


  • Moderators

    Also, this set of arguments assumes that gnome-terminal and bash are both in your path. Depending on your situation, you might want to use fully qualified paths.



  • yes it seams to work!! :)



  • THANK YOU!

    continuing coding


  • Moderators

    Be sure and update the thread title to add [Solved]. Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.