Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Creator fails to start on Windows 10



  • ive been using qt 5.6.1 for awhile now but all of a sudden qtcreator.exe will refuse to launch at all and windows error reporting service starts any time i try. ive been using qt since like 4.0 and never had any issue like this, iver tried installing fresh from qt-unified-windows-x86-3.0.4-online.exe on a fresh install of windows with all updates and it still does the same thing.
    the event log entry for the crash is the most useless ive ever seen,

    Faulting application name: qtcreator.exe, version: 4.4.1.0, time stamp: 0x59d43584
    Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x40000000
    Faulting process id: 0x6ac
    Faulting application start time: 0x01d3e224f6c241a2
    Faulting application path: G:\Qt\Qt5.9.2\Tools\QtCreator\bin\qtcreator.exe
    Faulting module path: unknown
    Report Id: 728a362f-0b50-440d-8137-c48ad069bcb1
    Faulting package full name: 
    Faulting package-relative application ID: 
    

    cant install the files in vcredist because windows says they are already installed and after googling some posts said to delete a file called "welcome.dll" but the closest i can find is "Welcome4.dll" and renaming it does nothing.
    what other possibilities are there short of ram/cpu failure? i tried from a different physical hard drive and havent noticed any problems with any other software.

    guess forget to mention trying to install it with mingw530_32 but my older version was using mingw492_32 and does the exact same thing.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Any chances of you having an update to Windows applied ?



  • which update? i tried from from a fresh install on windows with no updates and no amd drivers, then tried with graphics drivers then updated windows until before the "fall creators patch" because it wouldnt seem to install, i figured my phenom ii was too old for it.



  • Hi, just guessing, but if you have antivirus installed, try disabling it.



  • @hskoglund i tried with windows defender and firewall disabled but it still does the same thing. i read probably some old post saying it didnt like opera running but closing it doesnt change anything.



  • Ok. Also you can try to launch Qt Creator as Administrator, i.e. right-click on the icon and select "Run as Administrator"



  • i tried launching as admin, i also tried updating to qt 5.10.1, changing windows data execution prevention to "Turn on DEP for all programs and services except those I select:" and verifying the "Path" system variable includes the mingw bin directory in the qt version folder and the bin directory in tools/qtcreator folder.

    i tried changing the DEP because i seen

    Fault bucket 1511236979439112022, type 5
    Event Name: BEX
    Response: Not available
    Cab Id: 0
    
    Problem signature:
    P1: qtcreator.exe
    P2: 4.6.0.0
    P3: 5aba336c
    P4: StackHash_bdcb
    P5: 0.0.0.0
    P6: 00000000
    P7: PCH_E3_FROM_ntdll+0x000690BC
    P8: c0000005
    P9: 00000008
    P10: 
    
    Attached files:
    ***WERDE3C.tmp.WERInternalMetadata.xml
    
    These files may be available here:
    ***AppCrash_qtcreator.exe_4054daee17efbfa6d8b59a1792456c12b966137_3cdb21f6_0c1bdff1
    
    Analysis symbol: 
    Rechecking for solution: 0
    Report Id: e75f063b-0b22-44f2-83c2-828743344573
    Report Status: 0
    Hashed bucket: 618295179d559da2f4f8fe06a2e70f56
    

    that error seems more informative, not sure why i overlooked it earlier



  • Hmm, Qt Creator is more or less just like any other Qt-based program that's built using the 32-bit MSVC 2015 compiler.

    Have you tried VLC or Wireshark (they are built in a similar way as Qt Creator)?



  • @hskoglund vlc works fine as far as i tested, that being just opening a mp4 file, but it does launch and play the file.
    i have been using visual studio 2017 since qt refuses to work, havent tried qt with the visual c compiler though because i would rather use mingw as i always have and uninstall visual studio if i can. unity also works fine.



  • Ok one more: on your Windows 10, try creating a new user, log in as that user and then start Qt Creator.



  • @hskoglund i tried creating a new local account with a different username and running qtcreator from there and it still does the same thing but didnt reinstall anything



  • ok one last ditch: try to start Qt Creator without any plugins: open a CMD window:

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload all

    if that shows you a messagebox: "Failed to load core: Core plugin is disabled" then try again but loading the Core plugin:

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload all -load Core



  • @hskoglund -noload all still does the same. no error message, windows error reporting just appears in the task manager for a second and the log is added.
    i tried installing directx runtimes and adding windows sdk to the environment path but still the same. old apps ive made with qt still work fine though.
    i guess i will just have to try installing on linux sometime and continue from there, im baffled.



  • Hmmm, if you're curious you could always fire up the old Dependency Walker load Qt Creator into it and press F7 to start profiling it. It should show which .dll is the culprit...



  • Dependency Walker makes it to IMM32.dll then freezes up, some post on stackoverflow says it may need WDK. might be awhile before can download that.



  • found somewhat of a "solution", i downloaded and installed qt-creator-opensource-windows-x86_64-4.6.0 from http://download.qt.io/official_releases/qtcreator/4.6/4.6.0/ and qtcreator will actually open. have no idea why the version included with full qt and my previous installations just stopped working, guessing it has to do with 32bit versions even though ive always used 32 bit and has always worked from a fresh install of windows. thanks for all the suggestions though.



  • I'm having the same problem.

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload all
    

    produces an error:
    Failed to load core: Core plugin is disabled

    &

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload all -load Core
    

    launches a greyed out very minimalistic unusable Qtcreator window.

    I've installed Qt 5.14 with QtCreator 4.11 (MinGW 7.3.0 32bit). Please, help.


  • Qt Champions 2019

    @jyotib When go through the plug-ins and always disable only one until QtCreator starts.
    Usually Welcome plug-in is the one causing problems.



  • @jsulm But I've not disabled any.


  • Qt Champions 2019

    @jyotib said in Qt Creator fails to start on Windows 10:

    But I've not disabled any.

    You did: -noload all



  • @jsulm Is it possible that i didn't installed some components and that resulted in this situation? I followed this youtube video link text during installation. And i'm using windows 10 64 bit system.



  • @jyotib

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload welcome
    

    produces an error:

    The plugin "welcome" does not exist. What should I do?


  • Qt Champions 2019

    @jyotib said in Qt Creator fails to start on Windows 10:

    What should I do?

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload Welcome
    


  • @jsulm said in Qt Creator fails to start on Windows 10:

    C:\Qt\Tools\QtCreator\bin\qtcreator -noload Welcome

    that did nothing at all.


  • Qt Champions 2019

    @jyotib When I guess it is another plug-in. As I suggested before: go through all plug-ins and disable one in each step and see whether QtCreator starts or not.



  • I'm having a similar problem ... when I run QTCreator it does absolutely nothing ... what should I do to fix this?
    I'm using Windows 10 ¨64bit


  • Qt Champions 2019

    @Marcos-Queiroz said in Qt Creator fails to start on Windows 10:

    when I run QTCreator it does absolutely nothing

    Do you mean it does not start?
    Any anti-virus software running?
    How did you install QtCreator and which version?


Log in to reply