Important: Please read the Qt Code of Conduct -

QWebView crashes when charging google maps

  • This is an answer to link text because I don't know why askimet don'ty allow me to send messages. basically I'm trying to use google maps using qwebview but I don't know why the program keep crashing. Also using the new binaries provided by @Konstantin-Tokarev
    the program crashes. This is what I've done on a completely new machine and on a virgin installation of Qt:

    • I have downloaded the binaries from the link you have sent to me in particular this one qtwebkit-Windows-Windows_7-Mingw53-Windows-Windows_7-X86.7z.

    • I have unzipped the folder and i have copied the files into the respective folders in my D:\Programmi\Qt\5.10.0\mingw53_32 installation.

    • I have copied in the same folder as above also the libeay32.dll and ssleay32.dll for the OpenSSL.

    • My platform is windows 10 and I'm using qt 5.10.0 with MinGW53_32.

    • This is the code I tried:

    #include "mainwindow.h"
    #include <QApplication>
    #include <QtWebKitWidgets>
    int main(int argc, char *argv[])
        QApplication a(argc, argv);
    //    MainWindow w;
        QWebView *view = new QWebView;
        return a.exec();

    When I run it, It appears the google page, I search for google maps but when the map is completely charged it crashes. I don't give any inputs to the map so I really don't know what is causing the crash. Can somebody help me? Also with alternative solutions, I've been stuck at this for too long.

    Thanks for you help.

  • Are you using release build?

  • @Konstantin-Tokarev I tried both, debug and release mode, nothing changed a part from the fact that in release it's faster to crash.

  • hello there,
    I have the same problem. did you solve this?

Log in to reply