Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Cannot seem to load any images/bitmaps from QT Creators resource system



  • Thanks, yes, I know, I had been doing that all along, but It would't work no matter what.
    The only thing, that worked was reinstalling with most notably mingw53_32 selected in addition. Now at least the path version of the alias works, but nothing else.
    It must have something todo with the options you select when installing Qt+Qt Creator. Also maybe besides from mingw53_32 I selected another additional option during reinstallation,
    but that's all I changed on my configuration in order to get it to work.

    And yes the images/bitmaps show up fine inside the Qt creators designer, although
    sometimes you have to save your project with 'save all' before they do.
    But when the application was run after compilation, they didn't show up in the app.


  • Lifetime Qt Champion

    Just to be clear.
    It shows the icons when you browse them but when you run INSIDE creator its
    not showing the images that should be compiled into the exe?

    Or is it only if you go double click the exe in the build folder?

    There is nothing you can de-select during install that disables ressources.
    Its a core feature.

    Could you try this test project ?
    https://www.dropbox.com/s/dfrdoju7fhr9tan/untitled56.zip?dl=0



  • " It shows the icons when you browse them but when you run INSIDE creator its
    not showing the images that should be compiled into the exe?"

    Exactly;-)


  • Lifetime Qt Champion

    @mnob
    Ok, and test project also does this ?
    Check if "Compiler output" contains
    C:\Qt\5.10.0\msvc2015_64\bin\rcc.exe -name icons ..\untitled56\icons.qrc -o debug\qrc_icons.cpp
    ( or similar if using mingw. path will be different to rcc.exe)
    Sounds like they are not compiled in for some reason.



  • The "Burning Sun's Avatar" thing is showing when running the application after
    setting the project up with the msvc kit option.

    'D:\QT_2nd\5.10.1\msvc2017_64\bin\rcc.exe -name icons ..\untitled56\icons.qrc -o debug\qrc_icons.cpp' <-- This does indeed show up in compiler output so the test project seems to work just fine.


  • Lifetime Qt Champion

    Ok so your kit seems valid and rcc is run.

    Try to delete complete build folder for your project and
    run rebuild all and check if your project calls rcc.exe



  • rcc is called and the .png shows up :
    D:\QT_2nd\5.10.1\msvc2017_64\bin\rcc.exe -name resource ..\QComboBoxDemo\resource.qrc -o debug\qrc_resource.cpp

    but this is still the only synthax that works:

    ui->comboBox->addItem(QIcon(":/png/foo"),"Hanko");

    Also before reinstalling no synthax variant at all worked, that's for shure.
    But now image loading is feasable of course, so the problem is not that urgent anymore. Still it's strange why other synthax variants don't work as supposed, and why things only started to come together after reinstalling Qt+Qt Creator. Anyways...


  • Lifetime Qt Champion

    Hi
    That is a bit odd. But I have only used ":/" with icons and
    "qrc:/" with QML so would not have noticed if was broken once.
    Regarding the reinstall- maybe scanner ate rcc.exe the first time or something else
    blocked from being installed. Hard to guess at. its normally always included.



  • You mean anti-malware scanner? Well that would have to be windows defender then, since I don't have anything else installed of that nature.
    Is there maybe still a way to somehow exclude rcc from installation by making wrong selections in the dialogs during installation of Qt+Qt Creator? You said it's a core feature, but...


  • Lifetime Qt Champion

    @mnob
    Yeah, but its rare i have seen Defender eat anything so most likely something else.
    As far as I know, rcc i included in all precompiled and there is no option to not have it installed.



  • Hm, removed the mingw53_32 folder from the installation because I thought that
    maybe "QT Creator" itself somehow needed mingw53_32 to be present to function correctly, but nothing changed. The path to the alias still works correctly although
    other synthaxes don't work, but that seems to be another issue so maybe my build directory just got corrupted somehow. Anyhow thanks for your help.



  • The non-alias resource path works too now. Cool ;-)



  • You can't seem to use a non-alias resource path once an alias has been assigned.


  • Lifetime Qt Champion

    @mnob
    Like
    <file alias="cut-img.png">images/cut.png</file>
    and then you cannot use ":/images/cut-img.png" anymore ?



  • Exactly. Once an alias has been defined, I can access the resource by that alias exclusively.


  • Lifetime Qt Champion

    @mnob
    Ok, not sure if by design or not working.



  • Seems to be the same for Desktop_Qt_5_10_1_MinGW_32bit-Debug.

    Before I was using Desktop_Qt_5_10_1_MSVC2017_64bit-Debug.


  • Lifetime Qt Champion

    @mnob
    Hi
    I thinks by design. Its not ALSO listed under org name so
    only the alias name is available.



  • O.K. I see.



  • Seems like it helps to delete the build folder or clean project and run qmake+rebuild.


Log in to reply