Strange compilation error with Qt5.1 and msvc2015_64



  • I'm receiving the following errors:

    "C:\Qt\Qt5.10.0\5.10.0\msvc2015_64\mkspecs\features\toolchain.prf:205: error: Extra characters after test expression."
    ":-1: error: Compiler produced empty value for CreateFile:."

    It looks like this is directly related to qmake. I've reviewed the .pro file, as that seems to be the biggest issue when searching Google. I tried compiling using msvc2015_32 and it worked, so it seems localized to my kit. Any suggestions? Thanks in advance!


  • Qt Champions 2017

    hi
    So its not the usual missing \ at end of line in .pro file.
    Do you have any 32/64 checks in pro file ?
    Since 32 bit works, one could assume .pro is 100% ok ? or ?



  • I do not have checks for 32 bit, just for Windows:

    win32 {
        SOURCES += corewin.cpp
        HEADERS += corewin.h
    }
    

    I just pushed to our Jenkins instance and it compiled fine for Mac/Win/Linux 32 and 64. So I think this confirms it is a localized issue.


  • Qt Champions 2017

    Hi
    Indeed if same pro file works on others setups in 64 bit then must be kit.
    If you make a default new GUI project it can compile?



  • I did not think to test that. I created a new project and no, I cannot compile it. Same qmake error.


  • Qt Champions 2017

    @jbc22
    Ok so it really is something in the kit.
    Some file qmake uses that is damaged. (maybe)
    Would it be option to simple reinstall Qt or too huge setup for that?



  • @mrjj That fixed it. Thanks!


  • Qt Champions 2017

    Super,
    we could have spend long time comparing files to find the guilty one so re-install
    is so much more fun :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.