From 10:00 CET Friday 22nd November we will adjust how the server works to deal with some recently reported problems. Therefore there may be a load problem, if you experience more problems than usual trying to access the forum then please PM AndyS or any of the moderators so they can inform me.


QtWebEngine crosscompile linking want very large /tmp/sometempfile (memory exhausted error)



  • Hi
    I use the Ubuntu x64 for my host mashine to build rootfs for Fscale IMX6.
    I try build qtwebengine (Qt 5.9.1) by "buildroot" and have no success.
    All tasks for build *.so file is complited. Link step use all ram memory and a bit the swap. About 6...7 GB for this.
    Some time late i got an error "memory exhausted". So what I can do for succes?


  • Lifetime Qt Champion

    Hi,

    AFAIK, QtWebEngine (or rather its dependencies) need a lot of resources to build and link. So first thing: do you need that module ? If not, just don't build it. Otherwise... What are your machine specification ?

    By the way, you should consider updating the Qt version you are using, the latest of the 5.9 series is currently 5.9.4.



  • @SGaist I need qtwebengine functions. I want embed to my application the web browser.
    I try now build version 5.9.3 and have no success too. I got error "insufficient memory".
    I have i7, 4 GB of memory, 8 GB of swap.
    I built all modules of Qt5.9.3
    All built ok, but QtWebEngine - have no success.
    The last string of log is:
    /home/work/buildroots/defconfig/output/host/usr/bin/arm-buildroot-linux-gnueabihf-g++ --sysroot=/home/work/buildroots/defconfig/output/host/usr/arm-buildroot-linux-gnueabihf/sysroot -Wl,--no-undefined -Wl,--version-script,QtWebEngineCore.version -Wl,--gc-sections -Wl,-O1 -Wl,-z,now -Wl,-z,defs -Wl,--enable-new-dtags -shared -Wl,-soname,libQt5WebEngineCore.so.5 -o libQt5WebEngineCore.so.5.9.3 -lrt -lpthread -ldl -lQt5Quick -lQt5Qml -lQt5Gui -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Gui -lQt5Core -lrt -ldl -latomic -lpthread -lQt5WebChannel -lQt5Qml -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Qml -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Positioning -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Core -lrt -ldl -latomic -lpthread -lpthread @/home/work/buildroots/defconfig/output/build/qt5webengine-5.9.3/src/core/Debug/Qt5WebEngineCore.rsp -Wl,--start-group /home/work/buildroots/defconfig/output/build/qt5webengine-5.9.3/src/core/Debug/obj/base/libbase.a ...................here skipped many files star.a ........................ -lQt5Quick -lQt5Qml -lQt5Gui -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Gui -lQt5Core -lrt -ldl -latomic -lpthread -lQt5WebChannel -lQt5Qml -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Qml -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Positioning -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Core -lrt -ldl -latomic -lpthread -lGLESv2 -lEGL -lpthread -ldl -lrt -levent -lfontconfig -lfreetype -lexpat -lpng16 -lresolv -ldbus-1 -lavcodec -lavformat -lavutil -lopus -lasound -L/home/work/buildroots/defconfig/output/build/qt5webengine-5.9.3/src/core/api/Debug -Wl,-whole-archive -lqtwebenginecoreapi -Wl,-no-whole-archive -lEGL -lQt5Quick -lQt5Qml -lQt5Gui -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Gui -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Qml -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Network -lQt5Core -lrt -ldl -latomic -lpthread -lQt5Core -lrt -ldl -latomic -lpthread -lGLESv2 -lEGL
    /home/work/buildroots/defconfig/output/build/qt5webengine-5.9.3/src/core/Debug/obj/media/blink/libmedia_blink.a: error adding symbols: insufficient memory


  • Lifetime Qt Champion

    AFAIK, 4GB is way too low especially if you build a debug version.



  • @SGaist Wow... How many need of RAM for build qtwebengine?


  • Lifetime Qt Champion

    It's not QtWebEngine itself that is so hungry it's chromium that is the backend. See here for the linux requirements.



  • @SGaist Thank you very much. I will force my comp.


Log in to reply