Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QTCreator and Ubuntu(16.04 LST)



  • Hi!
    I started working on an already existing project and i have to edit and add some features. This project was written with QT 5.9 and OpenCV 2.4.9 : in order to emulate the starting developement environment i installed the same version of all the libraries needed. When i try to compile in QTCreator 4.3.1 (the one based on qt 5.9) i get no errors BUT when i try to run and then try to use my software i get some in the application output section.
    These errors are:
    "
    (vat:7666): GLib-GObject-WARNING **: cannot register existing type 'GdkWindow'

    (vat:7666): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

    (vat:7666): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

    (vat:7666): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
    "
    (the application then crash)
    I've already tried to find something on the web but the only things found were just someone saying that qt above 5.7 do not still support gtk and they suggest to install packages from git (qtstyleplugins, https://github.com/qt/qtstyleplugins ) but it seems not working for me(maybe i'm trying to install it in a wrong way)

    Is there someone that could help me?



  • @Unielli SOLVED!
    found out the problem. The issue was caused by the QFileDialog call. I had to change every call by adding the option: "DontUseNativeDialog". I hope this will help someone saving time ^_^


  • Qt Champions 2019

    @Unielli I'm not sure why you're building QtCreator by yourself. You can use any Qt version (ans as many as you need) with any QtCreator version. Means: if you want to use Qt5.9 you don't have to build QtCreator with Qt5.9 as it doesn't matter which Qt version QtCreator itself uses.


Log in to reply