windeployqt.exe VS depends.exe

  • Hi,
    I have used windeployqt.exe to deploy my app.

    My probleme is, when i run my application nothing happends ... no error message. It is not visible in Process Explorer. It just doesn't run.

    Even if i compile in Debug mode i have no error message.

    The only thing that makes me doubt is :
    I have added this in my .pro file
    unix|win32 : LIBS += -lWS2_32
    to use ws2_32.dll

    dependencywalker output :
    files missing :

    Can someone tell me what i have to do to solve this please ?

  • Lifetime Qt Champion


    What version of Qt ?
    What version of Windows ?

  • Hello @SGaist ,

    Qt version : 5.10.0 MinGW 32Bit2
    Windows 7

    Note : if i delete 'libstdc++-6.dll' from the path that 'windeployqt.exe' has created, then i try to start, i have an error (normal) , then i put that dll back and my app just dosn't start, without any error message.

  • I solved this probleme by putting my .exe inside :


    then I started my app and it worked.

    So I have copied all dll's + my .exe to a new path, and then started to delete dlls one by one and test run the app eatch time i delete one dll to see if it will run.

    So with windeployqt.exe i had :

    bearer / iconengines / imageformats platforminputcontexts / platforms / qmltooling / styles / translations
    D3Dcompiler_47.dll / libEGL.dll / libgcc_s_dw2-1.dll / libGLESV2.dll / libstdc++-6.dll / libwinpthread-1.dll / opengl32sw.dll /Qt5Core.dll / Qt5Gui.dll / Qt5Network.dll / Qt5Qml.dll / Qt5Quick.dll / Qt5Svg.dll / Qt5Widgets.dll / myApp.exe

    Now i have :

    bearer / iconengines / imageformats platforminputcontexts / platforms / qmltooling / styles / translations
    libstdc++-6.dll / Qt5Core.dll / Qt5Gui.dll / Qt5Network.dll / Qt5Quick.dll / Qt5QuickControls2.dll /Qt5QuickTemplates2.dll / myApp.exe

    and now my app starts correctly.


Log in to reply