Building Qt 5.10 debug on Windows Server 2012 R2 with VS2017

  • I ran into problems again when trying to compile QT 5.10 on windows server 2012 R2 with VS 2017.
    -> I deleted the complete qt-everywhere-src-5.10.0 folder and unziped from scratch.
    -> I removed following directories:
    -> Ran : configure.bat -static -release -debug -no-opengl -platform win32-msvc -opensource -confirm-license -nomake tests -prefix d:\qt\qt5.10
    -> nmake

    Eror : Debug Assertion Failed!
    Program: D:\QT\qt-everywhere-src-5.10.0\qtbase\bin\qlalr.exe
    file: minkernel\crts\ucrt\src\heap\debug_heap.cpp
    Line : 597
    Expression : _CrtlsValiedHeapPointer(block)
    (sorry if there are any typos I could not copy the text from the popup window.)
    followed by a window Qt Look Ahead LR Parser has stoppped working
    -> clicking close the program

    call D:\QT\qt-everywhere-src-5.10.0\qtremoteobjects\tools\repc\qlalr_wrapper.bat ....\src\repparser\parser.g
    NMAKE : fatal error U1077: 'call' : return code '0x80000003'
    NMAKE : fatal error U1077: '"D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.10.25017\bin\HostX86\x86\nmake.exe"' : return cod
    e '0x2'
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    NMAKE : fatal error U1077: 'cd' : return code '0x2'

    I had similar errors earlier but could continue to build.
    Is it possible that screen-lock has an impact on the compile process ?

    Earlier I build qt only with -rlease which worked. followed by adding the -debug option to the configure.bat. I could build it like that. But the issue that I reported earlier with the missing Depentent 'd:\qt\qt5.10\lib\QT5PrintSupportd.lib does not exist did not get solved by that. That's why I tried to build it from scratch again.

    [Edit]: I get similar error when compiling on my home system same setup except windows 10 pro.

  • Same problem here with Qt 5.11.0, happening with Visual 2015 but not Visual 2017, only when Qt is configured as -static and -debug, with or without -static-runtime :
    call C:.conan_nwtri\1\qtremoteobjects\tools\repc\qlalr_wrapper.bat C:.conan\2sjrgr\1\qt5\qtremoteobjects\src\repparser\parser.g
    NMAKE : fatal error U1077: 'call' : return code '0x3'

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.