QTCreator target device



  • Hi all,

    I just installed Qt Creator and Qt5-default on Ubuntu 17.10.
    I opened a project I have been working with before, to build it on and for this platform.

    To my surprise, the only large I could select was "remote QNX Device" (don't even know what this is), while I simply want to build, run and debug on my local PC platform. I will not work with embedded or Andorid platforms.

    How can I reconfigure Creator to do this?

    BN


  • Moderators

    @Bengt-0

    Hi and welcome to devnet forum

    How did you install Qt creator and Qt libs?

    AFAIK you need to install compatible gnu compiler separately. Did you tick on under tools a gnu c++ compiler?

    In creator under "Tools"->"Options"->"Build&Run" you can under different tabs if everything is installed properly.
    Check for warning and error signs and best post the information here.



  • I think I did it in the wrong order.
    I installed QtCreator first, and then Qt5-default.
    I restarted from scratch and reversed the order, Qt5-default and THEN QtCreator.
    Now it works.

    Thanks.


  • Moderators

    @Bengt-0

    Glad to hear that problem is solved.

    There are a couple of ways for installation. probably there is also the way through the linux distribution. Those are typically a bit outdated.

    Just for clarity my answer concering to tick on gnu c++ is for the online installer. There you get all in one package and installed at once.

    Please marked your thread as solved. You find "Mark as Solved" in the ComboBox "Topic Tools" under your posts.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.